Docker Community Forums

Share and learn in the Docker community.

Docker Redis cannot listen to port 6379

Hello ,

I install redis docker by the following line :
docker run --name myredis -d -p 6379:6379 redis

  • I using “telnet localhost:6379” >>>>>> no connection

  • Also I using “telnet {container Ip Address} 6379” >>>> also no connection

  • I writing the following command “docker ps” and the port value is “0.0.0.0:6379->6379/tcp

  • I run “docker logs {container Id}” :

      1:C 13 Mar 2019 12:15:11.714 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
    

1:C 13 Mar 2019 12:15:11.714 # Redis version=5.0.3, bits=64, commit=00000000, modified=0, pid=1, just started
1:C 13 Mar 2019 12:15:11.714 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
1:M 13 Mar 2019 12:15:11.715 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
1:M 13 Mar 2019 12:15:11.715 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
1:M 13 Mar 2019 12:15:11.715 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
1:M 13 Mar 2019 12:15:11.716 * Running mode=standalone, port=6379.
1:M 13 Mar 2019 12:15:11.716 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
1:M 13 Mar 2019 12:15:11.717 # Server initialized
1:M 13 Mar 2019 12:15:11.717 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
1:M 13 Mar 2019 12:15:11.717 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
1:M 13 Mar 2019 12:15:11.717 * Ready to accept connections

How Can I fix the error ?