Docker Community Forums

Share and learn in the Docker community.

Docker Run can't connect to https://index.docker.io

i finally got it to work. i had to uninstall openvpn. even though the network manager or the device manager were not showing any virtual device…

1 Like

I also having same problem, but after manually setting DNS to 8.8.8.8. It can connect now.

To everyone having this issue, can you paste the exact output of nslookup localhost?

The TCP/IP IPV4 DNS on the vEthernet (DockerNET) was empty. I set it to 8.8.8.8 and second nslookup/run worked.

PS C:\Users\csull> docker run hello-world
Unable to find image 'hello-world:latest' locally
Pulling repository docker.io/library/hello-world
C:\Program Files\Docker\Docker\Resources\bin\docker.exe: Network timed out while trying to connect to https://index.dock
er.io/v1/repositories/library/hello-world/images. You may want to check your internet connection or if you are behind a
proxy..
See 'C:\Program Files\Docker\Docker\Resources\bin\docker.exe run --help'.
PS C:\Users\csull> nslookup localhost
Server:  UnKnown
Address:  2601:8b:c300:1473:c256:27ff:feca:ca1c

Name:    localhost
Addresses:  ::1
          127.0.0.1

PS C:\Users\csull> nslookup localhost
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

*** google-public-dns-a.google.com can't find localhost: Non-existent domain
PS C:\Users\csull> docker run hello-world
Unable to find image 'hello-world:latest' locally
latest: Pulling from library/hello-world

4276590986f6: Pull complete
a3ed95caeb02: Pull complete
Digest: sha256:4f32210e234b4ad5cac92efacc0a3d602b02476c754f13d517e1ada048e5a8ba
Status: Downloaded newer image for hello-world:latest

Hello from Docker.
This message shows that your installation appears to be working correctly.

To generate this message, Docker took the following steps:
 1. The Docker client contacted the Docker daemon.
 2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
 3. The Docker daemon created a new container from that image which runs the
    executable that produces the output you are currently reading.
 4. The Docker daemon streamed that output to the Docker client, which sent it
    to your terminal.

To try something more ambitious, you can run an Ubuntu container with:
 $ docker run -it ubuntu bash

Share images, automate workflows, and more with a free Docker Hub account:
 https://hub.docker.com

For more examples and ideas, visit:
 https://docs.docker.com/engine/userguide/

Thank you so much. Same problem, same solution.

Windows 10 Enterprise 1511 (v10586.318).

Before trying Docker for Windows beta, these softwares were installed on my system :

  • VirtualBox
  • VMWare Workstation

My motherboard has 2 network interfaces, I had to disable one of these.

Hyper-V wasn’t installed on my system.

I uninstalled VirtualBox first then I installed Hyper-V.
After one or two reboots, I installed Docker for Windows.

After many uninstall/reinstall and config tricks, the only working solution was to remove the old “VirtualBox” registry key before doing a last full uninstall/reinstall.
By the way, I let my “vEthernet (DockerNAT)” at it’s default settings, and the interface is not configured to obtain IP and DNS automatically. It’s set with a fixed IP 10.0.75.1.

Thank you again @ruverav

1 Like

I was having the same problem until I uninstalled my VPN client that had a hidden network adapter installed. Once I uninstalled it it worked perfectly.

I’ve just realised it only works when using Experimental VPN compatibility mode enabled

I think using InstaForex service by Ildar Sharipov https://www.facebook.com/public/Ildar-Sharipov is the best option. I can ensure you won’t have any problems with this company because the guys have proved to be responsible for their business.