Docker Community Forums

Share and learn in the Docker community.

Error response from daemon: dial tcp 10.0.75.2:2375: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond


(Chribben) #1

Expected behavior

Connection between the host and the Docker VM instance working

Actual behavior

Connection between host and VM failing

Information

Docker for Windows version: 1.11.0-beta7 (build: 1692)
Host machine: Windows 10

Output from a docker command e.g. docker ps fails with error:
Error response from daemon: dial tcp 10.0.75.2:2375: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

A lot of the following in the log:
[16:39:27.661][Proxy ][Info ] 2016/04/18 16:39:27 listen udp 10.0.75.1:53: bind: The requested address is not valid in its context.
[16:39:27.669][Proxy ][Info ] 2016/04/18 16:39:27 Waiting for the port/IP to become available

Also seeing the following in the log (not sure it’s relevant):
[16:12:10.706][Proxy ][Info ] 2016/04/18 16:12:10 dhcp: There’s no lease available for 00:15:5d:4b:01:0b

Steps to reproduce the behavior

  1. Install Docker for Windows (beta-7) and run a docker command e.g. docker ps

(Hal9000msg) #2

I started to get the same problem after I’ve upgraded my windows to the Insider Preview version.
Windows 10 Pro Insider Preview
Version 1511
OS Build 14316.1000

I’ve tried doing a reset to factory defaults on docker but it did not help.


(Rolf Neugebauer) #3

We haven’t tested on the insider preview yet but had reports of a number of issues with it. We’ll take a look before the next Beat (Beta9) will be released.


(Chribben) #4

I don’t have the Insider Preview.
Windows 10 Pro
Version: 1511
Build: 10586.218


(Jamespaxi) #5

Same here unfortunately…


(Kouji Matsui) #6

I have same problem on Docker 1.11.0-beta8 (1832) with Windows IP 14316


(Ftnilsson) #8

see VM "MobyLinuxVM": The VM couldn't get an IP address after 60 tries. by removing all other internal switches you can get it to work


(Chribben) #9

Thanks but in my case there’s only one switch and it’s the DockerNAT.
I will continue trouble shooting tomorrow.


(Patrick Lang) #10

Can you give this a try? It’s a draft I wrote up after I saw a problem upgrading from one Windows Insider build to the next.

Symptoms

Most Docker commands will fail with a message similar to this

PS C:\WINDOWS\system32> docker images
Error response from daemon: dial tcp 10.0.75.2:2375: connectex: A connection attempt failed because the 
connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

Diagnosis

Before you try the workaround, double check the following.

Right click on the Docker icon on the taskbar, and choose “Logs”.

[16:50:14.698][Proxy          ][Info   ] 2016/04/26 16:50:14 listen tcp 10.0.75.1:53: bind: The requested address is not valid in its context.

If you see a failed bind on port 53 repeated frequently throughout the log, then this workaround may apply.

Next, Check the IP address assigned to the virtual network adapter for the Docker NAT:

PS C:\WINDOWS\system32> ipconfig

Windows IP Configuration

Ethernet adapter vEthernet (DockerNAT) 2:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::691d:bec6:ea35:fe26%18
   Autoconfiguration IPv4 Address. . : 169.254.254.38
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

If the IPv4 address is not 10.0.75.1, then this workaround applies.

Workaround

If you have seen this failure and your most recent Docker log matches, try the following:

  1. Right click on the Docker taskbar icon, and click “Exit”
  2. Open a Windows PowerShell prompt as Administrator, and run Remove-VMSwitch -Name DockerNAT
  3. In the same window, run netsh interface ipv4 reset
  4. Reboot the computer
  5. Try running Docker for Windows again

(Chribben) #11

Thanks for the suggestion!

Unfortunately it didn’t work. The switch was properly removed but after reboot and Docker starting, it’s failing complaining that DockerNAT already exists. If I then exit Docker and restart it, it does start but I’m still getting the same error as above.


(Chribben) #12

Finally got it working, here’s what I did:

  1. Turned off Hyper-V and rebooted
  2. Uninstalled Docker for Windows
  3. Went into the Device Manager and removed all obsolete Hyper-V switches and adapters
  4. Turned on Hyper-V, rebooted and reinstalled Docker for Windows

I’ve previously tried re-installing Docker for Windows but without success so I believe step 3 above was what made it work.


(Rolf Neugebauer) #13

Hi @chribben and @patricklang

thanks for the debug. As you may have seen on this and other threads, several users have experienced networking issues. We were finally able to reproduce a few of them and hopefully have fixes and workarounds in Beta10, scheduled for next week

Rolf


(Simonepicciani) #14

edit: I have resolved it

here are the exact steps that I have done the fix this (as always you mileage may vary)

  1. in powershell do docker ps and after a while it fails with the error in the title
  2. close docker and reopen
  3. open another admin powershell and redo docker ps this time it will fail immediately with an error about unreacheable host
  4. in device manager i have disabled and enabled the hyper V ethernet adapter
  5. In docker setting I have reset to factory defaults the docker application
  6. after it finished resetting, in the same admin powershell run docker ps and it will work


original post under here
I have the same problem, this pc is new (never installed any of the previous beta or docker toolbox) and running windows 10 pro, version 1511, build 10586.218 (italian version)

Here is my log, I can see the workaround is initialized but it doesn’t work

[11:44:51.145][HyperV ][Info ] Enabled workaround for Build 10586 VMSwitch issue [11:44:56.157][HyperV ][Info ] Creating Switch: DockerNAT... [11:44:58.360][HyperV ][Info ] Switch created. [11:44:58.532][HyperV ][Info ] Set IP address on switch [11:44:58.563][HyperV ][Info ] Creating Net NAT: DockerNAT... [11:44:58.594][HyperV ][Info ] Net NAT created. [11:44:58.625][HyperV ][Info ] Creading dynamic VHD: C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MobyLinuxVM.vhdx [11:44:59.794][HyperV ][Info ] Creating VM MobyLinuxVM... [11:45:04.664][HyperV ][Info ] VM created. [11:45:04.680][Dhcp ][Info ] Dhcp starting on port 67, on interface vEthernet (DockerNAT)... [11:45:04.729][Dhcp ][Info ] Dhcp started. [11:45:04.758][Proxy ][Info ] Starting com.docker.proxy [11:45:04.772][HyperV ][Info ] Start [11:45:04.777][PowerShell ][Info ] Run script with parameters: -Start True... [11:45:04.848][Proxy ][Info ] docker proxy (on deprecated port): ready [11:45:04.863][Proxy ][Info ] poison pill: ready [11:45:04.863][Proxy ][Info ] dns server: ready [11:45:04.876][Proxy ][Info ] docker proxy: ready [11:45:05.822][HyperV ][Info ] Starting VM MobyLinuxVM... [11:45:06.795][HyperV ][Info ] Wait for the VM to get an IP address

let me know if i can give further details


(Eduardo Lucas) #15

In my case the solution was:

  • Disable the “DockerNAT” network adapter
  • Run the “Reset to factory defaults” via the taskbar / docker / settings / Reset to factory defaults"
  • Disable the “IP6” on the “DockerNAT” network adapter
  • Disable and re-enable the “DockerNAT” network adapter

My installation was working, but then after some hours of inactivity it didn’t anymore.
I could not ping 10.0.75.2 and could not run any docker commands.
After the two steps above, ping was re-established and docker started working again.


(dcormier) #16

I’m getting the same error. My Docker log is here (since I’m too new to attach a file). It has a lot of this:

[12:23:11.733][Proxy          ][Info   ] listen udp 10.0.75.1:53: bind: An attempt was made to access a socket in a way forbidden by its access permissions.
[12:23:11.739][Proxy          ][Info   ] Waiting for the port/IP to become available
[12:23:16.733][Proxy          ][Info   ] listen udp 10.0.75.1:53: bind: An attempt was made to access a socket in a way forbidden by its access permissions.
[12:23:16.737][Proxy          ][Info   ] Waiting for the port/IP to become available
[12:23:21.734][Proxy          ][Info   ] listen udp 10.0.75.1:53: bind: An attempt was made to access a socket in a way forbidden by its access permissions.
[12:23:21.738][Proxy          ][Info   ] Waiting for the port/IP to become available
[12:23:26.734][Proxy          ][Info   ] listen udp 10.0.75.1:53: bind: An attempt was made to access a socket in a way forbidden by its access permissions.
[12:23:26.738][Proxy          ][Info   ] Waiting for the port/IP to become available
[12:23:31.735][Proxy          ][Info   ] listen udp 10.0.75.1:53: bind: An attempt was made to access a socket in a way forbidden by its access permissions.
[12:23:31.739][Proxy          ][Info   ] Waiting for the port/IP to become available

Output from docker version:

Client:
 Version:      1.11.1
 API version:  1.23
 Go version:   go1.5.4
 Git commit:   5604cbe
 Built:        Wed Apr 27 00:34:20 2016
 OS/Arch:      windows/amd64
Error response from daemon: dial tcp 10.0.75.2:2375: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

(dcormier) #17

Today I saw there was an update available, and it seems to have resolved the issue for me.


(Dallonf) #18

For what it’s worth, I experienced the same error (not on an Insider Win10 build) and and was able to resolve it just by doing a factory reset on Docker.


(Markenson) #19

Additional information: Same error for me. Solved after factory reset too (windows 10 pro)


(Ttermeer) #20

Same problem here. Reset to factory ( without disabling anything ) solved it.