Docker service failed : Job for docker.service failed because the control process exited with error code

I am working on Jetson Orin AGX, and I tried to modify the /etc/docker/daemon.json by adding "default-runtime": "nvidia" and after modifying this when I did sudo systemctl restart docker got the following

Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.

then when I check the service status I got the following

nvidia@ubuntu:/etc/docker$ systemctl status docker.service
× docker.service - Docker Application Container Engine
 Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Drop-In: /etc/systemd/system/docker.service.d
 Active: failed (Result: exit-code) since Thu 2024-02-15 12:05:57 IST; 55s ago
TriggeredBy: × docker.socket
Process: 11453 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
Main PID: 11453 (code=exited, status=1/FAILURE)
    CPU: 312ms

Feb 15 12:05:57 ubuntu systemd[1]: docker.service: Scheduled restart job, restart counter is at 3.
Feb 15 12:05:57 ubuntu systemd[1]: Stopped Docker Application Container Engine.
Feb 15 12:05:57 ubuntu systemd[1]: docker.service: Start request repeated too quickly.
Feb 15 12:05:57 ubuntu systemd[1]: docker.service: Failed with result 'exit-code'.
Feb 15 12:05:57 ubuntu systemd[1]: Failed to start Docker Application Container Engine.

and for sudo dockerd --debug I get the error message as follows

failed to start daemon: Error initializing network controller: error obtaining controller instance: failed to register "bridge" driver: unable to add return rule in DOCKER-ISOLATION-STAGE-1 chain:  (iptables failed: iptables --wait -A DOCKER-ISOLATION-STAGE-1 -j RETURN: iptables v1.8.7 (nf_tables):  RULE_APPEND failed (No such file or directory): rule in chain DOCKER-ISOLATION-STAGE-1
(exit status 4))

I reloaded the daemon.josn using systemctl daemon-reload but the docker service did not start,can anyone help me resolve the issue?

same exact issue on Jetson Orin Nano developer kit 6.0DP
was working perfectly for a month until today morning

Start-Date: 2024-02-15 15:44:15
Commandline: aptdaemon role=‘role-commit-packages’ sender=‘:1.122’
Upgrade: libxtables12:arm64 (1.8.7-1ubuntu5.1, 1.8.7-1ubuntu5.2), coreutils:arm64 (8.32-4.1ubuntu1, 8.32-4.1ubuntu1.1), bind9-host:arm64 (1:9.18.18-0ubuntu0.22.04.1, 1:9.18.18-0ubuntu0.22.04.2), iptables:arm64 (1.8.7-1ubuntu5.1, 1.8.7-1ubuntu5.2), libgdm1:arm64 (42.0-1ubuntu7.22.04.3, 42.0-1ubuntu7.22.04.4), qemu-efi-aarch64:arm64 (2022.02-3ubuntu0.22.04.1, 2022.02-3ubuntu0.22.04.2), libip4tc2:arm64 (1.8.7-1ubuntu5.1, 1.8.7-1ubuntu5.2), gir1.2-javascriptcoregtk-4.0:arm64 (2.42.4-0ubuntu0.22.04.1, 2.42.5-0ubuntu0.22.04.2), gir1.2-webkit2-4.0:arm64 (2.42.4-0ubuntu0.22.04.1, 2.42.5-0ubuntu0.22.04.2), gdm3:arm64 (42.0-1ubuntu7.22.04.3, 42.0-1ubuntu7.22.04.4), box64-generic-arm:arm64 (0.2.7+20240207T061856.3548195-1, 0.2.7+20240215T061908.549e042-1), libjavascriptcoregtk-4.0-18:arm64 (2.42.4-0ubuntu0.22.04.1, 2.42.5-0ubuntu0.22.04.2), libip6tc2:arm64 (1.8.7-1ubuntu5.1, 1.8.7-1ubuntu5.2), gir1.2-gdm-1.0:arm64 (42.0-1ubuntu7.22.04.3, 42.0-1ubuntu7.22.04.4), bind9-libs:arm64 (1:9.18.18-0ubuntu0.22.04.1, 1:9.18.18-0ubuntu0.22.04.2), libwebkit2gtk-4.0-37:arm64 (2.42.4-0ubuntu0.22.04.1, 2.42.5-0ubuntu0.22.04.2), libde265-0:arm64 (1.0.8-1, 1.0.8-1ubuntu0.1), qemu-efi:arm64 (2022.02-3ubuntu0.22.04.1, 2022.02-3ubuntu0.22.04.2), dns-root-data:arm64 (2021011101, 2023112702~ubuntu0.22.04.1), linux-libc-dev:arm64 (5.15.0-92.102, 5.15.0-94.104)
End-Date: 2024-02-15 15:44:55

Start-Date: 2024-02-16 13:28:41
Commandline: packagekit role=‘update-packages’
Upgrade: libglx-mesa0:arm64 (23.0.4-0ubuntu1~22.04.1, 23.2.1-1ubuntu3.1~22.04.2), python3-distupgrade:arm64 (1:22.04.17, 1:22.04.19), language-pack-en-base:arm64 (1:22.04+20230801, 1:22.04+20240212), libgbm1:arm64 (23.0.4-0ubuntu1~22.04.1, 23.2.1-1ubuntu3.1~22.04.2), libgbm-dev:arm64 (23.0.4-0ubuntu1~22.04.1, 23.2.1-1ubuntu3.1~22.04.2), ubuntu-release-upgrader-gtk:arm64 (1:22.04.17, 1:22.04.19), language-pack-en:arm64 (1:22.04+20230801, 1:22.04+20240212), language-pack-he:arm64 (1:22.04+20230801, 1:22.04+20240212), python-apt-common:arm64 (2.4.0ubuntu2, 2.4.0ubuntu3), libgl1-mesa-dev:arm64 (23.0.4-0ubuntu1~22.04.1, 23.2.1-1ubuntu3.1~22.04.2), libgl1-mesa-dri:arm64 (23.0.4-0ubuntu1~22.04.1, 23.2.1-1ubuntu3.1~22.04.2), box64-generic-arm:arm64 (0.2.7+20240215T061908.549e042-1, 0.2.7+20240216T061842.f4fd01c-1), base-files:arm64 (12ubuntu4.5, 12ubuntu4.6), python3-apt:arm64 (2.4.0ubuntu2, 2.4.0ubuntu3), language-pack-he-base:arm64 (1:22.04+20230801, 1:22.04+20240212), login:arm64 (1:4.8.1-2ubuntu2.1, 1:4.8.1-2ubuntu2.2), libglapi-mesa:arm64 (23.0.4-0ubuntu1~22.04.1, 23.2.1-1ubuntu3.1~22.04.2), language-pack-gnome-he:arm64 (1:22.04+20230801, 1:22.04+20240212), unzip:arm64 (6.0-26ubuntu3.1, 6.0-26ubuntu3.2), libegl-mesa0:arm64 (23.0.4-0ubuntu1~22.04.1, 23.2.1-1ubuntu3.1~22.04.2), ubuntu-release-upgrader-core:arm64 (1:22.04.17, 1:22.04.19), language-pack-gnome-he-base:arm64 (1:22.04+20230801, 1:22.04+20240212), passwd:arm64 (1:4.8.1-2ubuntu2.1, 1:4.8.1-2ubuntu2.2)
End-Date: 2024-02-16 13:29:07

these are the last two suspected updates that broken docker

Just happened to me after the morning update. Reinstall docker-ce:

sudo apt reinstall docker-ce

Fixed the problem for me.

Unfortunately, I reflash my device. Now the issue is resolved.

I had the same problem start on the 14th after updating docker on Orin Nano 6.0 DP. I tried sudo apt reinstall docker-ce but that didn’t help unfortunately. I’m going to start a thread on the Nvidia Developer Forums and reference this one.

Nvidia Developer Forums issue: Docker gives error after upgrading ubuntu - Jetson AGX Orin - NVIDIA Developer Forums

1 Like

Someone posted a fix in that thread that worked for me as well:

sudo update-alternatives --set iptables /usr/sbin/iptables-legacy
sudo apt reinstall docker-ce

1 Like

Hi there

I also met this problem

Please check /etc/docker/ If there is file named daemon.json

sudo rm -f /etc/docker/daemon.json

and then try deleting it and again run

sudo systemctl start docker
sudo systemctl daemon-reload
sudo systemctl restart docker

This way work for me

1 Like