Docker Community Forums

Share and learn in the Docker community.

Docker-squash is not working

docker

(Rajadocker) #1

Hi All ,

I tried to squash the image using docker file. my docker version is 1.13.0.

Looks like it is not working. Image size is not getting reduces after running the squash command.

this is my docker file.

FROM debian:stretch

#Install the requirements (python, pyshpere, etc…)
RUN apt-get -y update && apt-get -y upgrade
RUN DEBIAN_FRONTEND=noninteractive apt-get -y dist-upgrade
RUN DEBIAN_FRONTEND=noninteractive apt-get -y install software-properties-common
RUN apt-get install -y python python-dev python-distribute python-pip openssl default-libmysqlclient-dev apt-utils python-dev libssl-dev libffi-dev build-essential sshpass
RUN pip install --upgrade pip
COPY 1g.img /
RUN pip install -U pysphere
RUN pip install python-subunit pytz junitxml subunit2sql mysql-python
RUN easy_install nose-subunit
CMD rm -rf /1g.img
RUN apt-get -y update

since i copy the file in one layer and remove in later layer , ideally once i run the squash command , i should get size reduced. but that is not happening.

any idea what could be the issue.

below is the command i used to squash the image.

docker save 54d80a63cdf8 | sudo docker-squash -verbose | docker load


(Yves Junqueira) #2

I believe docker-squash is broken in recent versions of docker: https://github.com/jwilder/docker-squash/issues/72