Docker Community Forums

Share and learn in the Docker community.

Docker Swarm ingress networking on WS2019 does not connect other containers or services on host

Hello all,

I am struggling with docker EE on Windows Server 2019. I have set up a WS 2019 Hyper-V Virtual Machine with a Windows 10 Host. I planned to experiment with docker and swarm. We are developing a micro-services application that we plan to run it on the swarm, and we need to use WS2019, therefore switching to Linux is a no-go.

I am able initialize a Swarm manager node, add other nodes (Another Hyper-v VM and the Host OS Windows 10). I can also create some simple services, publish ports and they are accessible from outside. The problem is that these containers cannot find eachother by service name. Furthermore, they cannot ping the container host VM, the Hyper-v Host OS or any other VMs connected to virtual switch. Also, I cannot access Internet from inside the container.

Moreover, when I deploy my application stack, I cannot use the service names to connect to services. It seems like the names are resolved, and the request is sent to some IP of the service, but there is no response. I cannot access Internet again.

I have also set up an Azure Virtual Machine to experiment. Somehow I was able to ping some outside hosts such as www.google.com. However, still could not connect or ping to the host. I have tried all the IP addresses available on either of the hosts. I haven’t tried to deploy my stack on Azure yet though, I am wondering if that would work.

I am wondering what I am missing? Is that a docker problem, or my Networking is faulty?. I have a nat and an external virtual switch for Hyper-v. Are there any people experiencing these problems?