Docker Community Forums

Share and learn in the Docker community.

Docker takes forever to start

I’m still struggling with the problem that it seems to take Docker forever to start. I’m running Windows 10 fast ring (version 14901.1000) but I’ve had this problem for a few weeks now. The hang up appears to be anything concerning the firewall, but I double-checked and there’s an inbound rule configured for “DockerProxy”. I even tried stopping the firewall and it doesn’t seem to help.

Here’s a chunk of the log, notice the huge gaps when dealing with ports:

[07:45:57.538][Firewall       ][Info   ] Closing ports...
[07:54:23.189][Firewall       ][Info   ] Ports are closed
[07:54:23.193][HyperVGuids    ][Info   ] Removing GUIDs...
[07:54:23.199][HyperVGuids    ][Info   ] GUIDs removed
[07:54:23.204][NamedPipeServer][Info   ] Destroy done.
[07:54:23.218][NamedPipeServer][Info   ] Start(Docker.Core.Settings)
[07:54:23.222][HyperVGuids    ][Info   ] Installing GUIDs...
[07:54:23.227][HyperVGuids    ][Info   ] GUIDs installed
[07:54:23.231][Firewall       ][Info   ] Opening ports for C:\Program Files\Docker\Docker\Resources\com.docker.proxy.exe...
[08:02:53.318][Firewall       ][Info   ] Ports are opened

Anyone have any ideas??

2 Likes

Had similar issue with 1.12.1 where it would hang no matter if firewall was on, off or replaced by an antivirus firewall. The solution was to disable windows firewall service altogether.

I have the same issue. Windows 10 latest stable (14393.479)

Docker 1.12.3 (8488)

Same log, same behavior

[12:17:32.740][NamedPipeClient][Info   ] Received response for Stop
[12:17:32.728][NamedPipeServer][Info   ] Stop done.
[12:17:32.746][NamedPipeClient][Info   ] Sending Start(Docker.Core.Settings)...
[12:17:32.757][NamedPipeServer][Info   ] Start(Docker.Core.Settings)
[12:17:32.764][HyperVGuids    ][Info   ] Installing GUIDs...
[12:17:32.770][HyperVGuids    ][Info   ] GUIDs installed
[12:17:32.775][Firewall       ][Info   ] Opening ports for C:\Program Files\Docker\Docker\Resources\com.docker.proxy.exe...
[12:27:32.612][SegmentApi     ][Info   ] Usage statistic: heartbeat
[12:55:12.349][SegmentApi     ][Info   ] Usage statistic: actionMenuSettings
[12:55:28.674][SegmentApi     ][Info   ] Usage statistic: actionMenuAbout
[12:57:58.243][SegmentApi     ][Info   ] Usage statistic: actionMenuAbout
[12:58:40.201][SegmentApi     ][Info   ] Usage statistic: actionMenuFeedback
[12:58:41.874][FeedbackSettings][Info   ] Open logs

Still starting up and MobiLinuxVM OFF

Could I ask you to try the beta channel? It has lots of recent improvements. If the problem persists with the beta version, please run the diagnostics and open an issue here: https://github.com/docker/for-win/issues

Hello,

I tried the beta but was a disaster so I came back to stable.

I have one work around. Disable the network card and enable it again. In about one minute Docker starts.

But the best workaround I’ve found is to Shutdown (not restart) the PC. When it starts again, docker starts almost instantaneous.

Regards

After a lot of time, seems like the version 17.09.0-ce-win33 (13620) doesn’t have this problem

solution is simply wait (the world won’t stop #TakeItEazy #worksmartnothard :slight_smile: )

A slow computer is often caused by too many programs running simultaneously, taking up processing power and reducing the PC’s performance. … click the CPU, Memory, and Disk headers to sort the programs that are running on your computer by how much of your computer’s resources they are taking.

Regards,
Jerry

thank you so much for the information
merchant crypto