Docker Community Forums

Share and learn in the Docker community.

Docker Tutorial Part 5: Visualizer error

I’m going through the Docker tutorial on a mac (OSX 10.12.5).

Docker downloaded yesterday so I think I should have the latest stable release. I did choose the stable release anyway.
I went over part 1 through 4 all without a problem. Now I’m at:


and I changed the docker-compose.yml file as told by the tutorial. I copied it over to myvm1 as stated in the tutorial and now I should run:

docker-machine ssh myvm1 “docker stack deploy -c docker-compose.yml getstartedlab”

Which is giving me as output:

visualizer Additional property visualizer is not allowed
exit status 1

And that is not what I or the tutorial is expecting.

I did a copy/paste of the content of the file replacing my info on the correct location. So a typo in the docker-compose.yml file is not likely.

What could cause this eretic behaviour?

Had the same issue. I also copy pasted from the tutorial. The “visualizer” service should be intended in the file. Added a couple of spaces before the “visualizer” and tried again and it worked for me.

I’m having the same issue here. Adding extra space didn’t help.

Hi,

Also got stuck in same , No one posted solution for this till now ??

If anyone found the solution please post.

I tried to pull “dockersamples/visualizer:stable”

but then i found this error “line 18: found character that cannot start any token”

for the text “visualizer:”

image

Edit : Found solution

There is a Tab in the file in my case its on line 19 not 18 , Tab is not allowed so check for tab in your file and replace it with space

Thanks

1 Like

yml is indentation style
fixing the indent fixed the problem…

This is posted for posterity. Thanks.

copy the docker-compose.yml from another place, then it works

I had the same issue, and deleted all my .yml contents -> pasted direct from tutorial. Worked! Hope you find the issue.