Docker Community Forums

Share and learn in the Docker community.

Docker wont work in raspberry pi zero w

this is a fresh instal of docker in raspberry pi zero w using curl -sSL https://get.docker.com | sh

I tried

docker volume create --name $OVPN_DATA

Then I get:

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

Tried to restart:

systemctl start docker
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start 'docker.service'.
Multiple identities can be used for authentication:
 1.  ,,, (pi)
 2.  root
Choose identity to authenticate as (1-2): 1
Password: 
==== AUTHENTICATION COMPLETE ===
Job for docker.service failed because a fatal signal was delivered causing the control process to dump core.
See "systemctl status docker.service" and "journalctl -xe" for details.

Then:

pi@raspberrypi:~ $ systemctl status docker.service
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: core-dump) since Tue 2019-05-28 02:35:26 BST; 23s ago
     Docs: https://docs.docker.com
  Process: 10074 ExecStart=/usr/bin/dockerd -H unix:// (code=dumped, signal=SEGV)
 Main PID: 10074 (code=dumped, signal=SEGV)
      CPU: 431ms

May 28 02:35:26 raspberrypi systemd[1]: docker.service: Unit entered failed state.
May 28 02:35:26 raspberrypi systemd[1]: docker.service: Failed with result 'core-dump'.
May 28 02:35:26 raspberrypi systemd[1]: Stopped Docker Application Container Engine.

I’m on a rasbperry pi zero w with the newest raspbian desktop

https://github.com/docker/for-linux/issues/490 didn’t help

I also tried installing older versions (I don’t remember how) and the daemon runned but I couldn’t run any docker image