Docker Community Forums

Share and learn in the Docker community.

Does not working if wifi turned off

I were travelled yesterday and wanted to work in airplane. So I have turned wifi off and…

Expected behavior

Expected to have docker working same as VM version

Actual behavior

Some docker containers were runned, all of them were kicked off and on next try docker did not started.

APIError: 502 Server Error: Bad Gateway (“Bad response from Docker engine”)

Information

  • the output of:
    • pinata diagnose -u on OSX
    • DockerDebugInfo.ps1 using Powershell on Windows
  • a reproducible case if this is a bug, Dockerfiles FTW
  • page URL if this is a docs issue or the name of a man page
  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

api_1 | [6] - Worker 1 (pid: 19) booted, phase: 0
w^[[Aapi_1 | [6] ! Terminating timed out worker: 12
api_1 | [6] ! Terminating timed out worker: 19
Exception in thread Thread-4:
Traceback (most recent call last):
File “threading.py”, line 810, in __bootstrap_inner
File “threading.py”, line 763, in run
File “compose/cli/log_printer.py”, line 190, in watch_events
File “compose/project.py”, line 343, in events
File “site-packages/docker/client.py”, line 233, in _stream_helper
File “json/init.py”, line 338, in loads
File “json/decoder.py”, line 369, in decode
ValueError: Extra data: line 2 column 1 - line 3 column 1 (char 660 - 1340)

Exception in thread Thread-3:
Traceback (most recent call last):
File “threading.py”, line 810, in __bootstrap_inner
File “threading.py”, line 763, in run
File “compose/cli/log_printer.py”, line 149, in tail_container_logs
File “compose/cli/log_printer.py”, line 179, in wait_on_exit
File “compose/container.py”, line 239, in wait
File “site-packages/docker/utils/decorators.py”, line 21, in wrapped
File “site-packages/docker/api/container.py”, line 439, in wait
File “site-packages/docker/client.py”, line 154, in _raise_for_status
APIError: 502 Server Error: Bad Gateway (“Bad response from Docker engine”)

Steps to reproduce the behavior

  1. turn off wifi
  2. try to do operatons with docker in a while (immediately if just does not work)

Any news on that? I would like to use docker when Internet is off too.

Tested it, turned off wifi for 10 minutes and have tried to use docker. it worked. Hopefully this issue just fixed.