Docker Community Forums

Share and learn in the Docker community.

Docker cli stopped working - reset installation solved it!


(Solitude) #1

Expected behavior

docker ps to list no running containers (newly restarted computer)
docker images to list downloaded images
docker run hello-world to download and run the hello-world

Actual behavior

docker ps timeout
docker images timeout
docker run hello-world timeout

Information

  • the output of:
    • pinata diagnose -u on OSX
    • DockerDebugInfo.ps1 using Powershell on Windows
  • a reproducible case if this is a bug, Dockerfiles FTW
  • page URL if this is a docs issue or the name of a man page
  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

Steps to reproduce the behavior

  1. Unfortunately I’m not sure what I’ve done… I’ve spent the morning trying to fix autocompletion in bash, had an update of docker yesterday, but haven’t used it since then. So I’m not sure if this is due to my non-understanding of the “fixes” I’ve done with bash or if it’s due to the update.

Diagnostic ID: 049D45B3-13EF-49AD-8C1D-7E1AF9B4D47A
Details:
Docker for Mac: version: v1.11.1-beta14.5.m OS X: version 10.11.5 (build: 15F34) logs: /tmp/20160608-092343.tar.gz failure: docker ps failed: Failure("docker ps: timeout after 10.00s") [ERROR] docker-cli docker ps failed [OK] app [OK] menubar [OK] virtualization [OK] system [OK] osxfs [OK] db [OK] slirp [OK] moby-console [OK] logs [OK] vmnetd [OK] env [OK] moby [OK] driver.amd64-linux


(Hamzakc) #2

Hi

I am getting the same error. I just installed the latest version, hoping for a fix. But it still cannot connect to the docker cli

Here is the Diagnostic ID:

D6A2682A-52C9-466C-AB87-40CE92ABD849

Thanks.
Hamza


(Solitude) #3

Solved this issue by selecting Settings -> Uninstall/Reset -> Reset.
Provided my access key, copied old configurations etc. Then docker hanged on “Docker is starting…” for a long while. Tired of that, so selected Quit Docker. Started docker again, run the diagnostic, all is well. Tried out “docker images” and it worked.

TL;DR
Reseted docker installation -> made sure it was fully started -> worked


(Phil Cockfield) #4

I’m getting this on a regular basis - docker on OSX dies about every day, and requires a reset and subsequent re-pull of all images, as you have been doing @solitude with

Settings -> Uninstall/Reset -> Reset

@solitude is this happening as regularly for you as it is for me? Or am I an outlier. Every day needing to reset and download is a bummer.

Also, is there a way to reset Docker and get this working again without destroying the pulled images?

Thanks


(Phil Cockfield) #5

Just happened again. Here’s the diagnostic:

12841D49-CE45-40AD-9F02-89C6725FCF3E


(Solitude) #6

@philcockfield no, it was only that one time. Doesn’t seem reasonable to have to reset every day. Just restart doesn’t help?