Docker Community Forums

Share and learn in the Docker community.

DTR login x509 certificate issues for internal ip not host

Hello Experts,

a bit of a Newbie question here,

Background, unable to login to DTR from cli on UCP host
Dcoker EE 19.03.8 running on ubuntu 18.04.4
UCP V3.3.0
DTR 2.8.0

whenever I try to login from Docker CLI to my freshly installed DTR environment, I get the following error,
response from daemon: Get https://DTRhostIP/v2/: x509: certificate is valid for 172.17.0.1, not DTRhostIP

I have tried reconfiguring DTR to use the CA internal self-signed certificate from UCP

docker run --rm -it
docker/dtr reconfigure
–ucp-url https://:443/
–ucp-username admin
–ucp-ca “$(cat ca.pem)”
–nfs-storage-url nfs://NFSIP/mnt/nfs_share --async-nfs --storage-migrated

I even tried from the worker nodes running the DTR and the same host,
but still no luck

as well as checked if any proxy details are in the environment variables using
sudo systemctl show --property=Environment docker , it returned empty value.

can you please guide me in the right direction?
Thank you in Advance