Docker Community Forums

Share and learn in the Docker community.

Error after installing DOCKER on Windows 10

After installing DOCKER on my Windows 10 PC; i opened a Power Shell window to run:

docker run hello-world

But it resulted on the following error:

Unable to find image ‘hello-world:latest’ locally
latest: Pulling from library/hello-world
a35da61c3562: Extracting 101.1MB/101.1MB
be21f08f6701: Download complete
10d1439be4eb: Download complete
C:\Program Files\Docker\Docker\resources\bin\docker.exe: failed to register layer: re-exec error: exit status 1: output: Failed to safefile.OpenRelative failed in Win32: open \?\C:\ProgramData\Docker\windowsfilter\70423a6e550df06abfcf8a974e3e7be2213ebb6853347b048131dd71fea9931f\Files\Users\Public: Access is denied. (0x1f) Files\Users\Public.
See ‘C:\Program Files\Docker\Docker\resources\bin\docker.exe run --help’.

Please help me.
Best regards

@movs681221

Any luck in terms of progress?

I failed to do “docker run hello-world” as well, same error. Want to know how to solve it and move on.

Thanks.

I solved this issue after switching to Linux containers from Windows containers.

To be able to switch to Linux container, Hyper-V and Visualization (enable it in BIOS) must be enabled.