Docker Community Forums

Share and learn in the Docker community.

Error after installing docker in windows

Aftre installing docker on windows, I am reciving the below error when I try to pull images from the server.

can you post the error? :slight_smile:

Installed docker as an administrator on my Windows 10 Enterprise machine by downloading from and started running the commands in windows powershell mentioned in link to check whether docker working properly or not.

Below is the error I am experiencing: (failed to register layer: rename)
PS C:\Users\XXXXX> docker run hello-world
Unable to find image ‘hello-world:latest’ locally
latest: Pulling from library/hello-world
e46172273a4e: Extracting [==================================================>] 92.82MB/92.82MB
a3e3c1bcacdf: Download complete
5912958fe266: Download complete
b7394e3f86f1: Download complete
C:\Program Files\Docker\Docker\Resources\bin\docker.exe: failed to register layer: rename C:\ProgramData\Docker\image\windowsfilter\layerdb\tmp\write-set-909648550 C:\ProgramData\Docker\image\windowsfilter\layerdb\sha256\bc06b22070cd8fb7c81b24025f0d67ed17390339fd8506cc46ce0224ec9c6e73: Access is denied.
See ‘C:\Program Files\Docker\Docker\Resources\bin\docker.exe run --help’.

Mc afee is running but I cannot stop the scanning as this is not approved by my organisation.

I have the same problem.

Same error happening to me, update to Mcafee endpoint security 10.7 since that one seems to be compatible with docker but still getting same error

ERROR: failed to register layer: rename G:\Dockerdata\image\lcow\layerdb\tmp\write-set-680418103 G:\Dockerdata\image\lcow\layerdb\sha256\e41e54adaade0c94ec6bc0a050bf1cec13741d2203a45c6847e3d72bf69ed2c8: Access is denied.