Docker Community Forums

Share and learn in the Docker community.

Error: connect ENOENT //./pipe/docker_engine

I have setup KM 1.12, VB 5.1.6, on win10, double clicking "Kitematic (Alpha) ", I get
Error: connect ENOENT //./pipe/docker_engine
with 2 buttons “Retry setup” or “Use VirtualBox”. I close and run the “Docker Quickstart Terminal”, everything works correctly and default machine is created and can play with docker.

I then rerun "Kitematic (Alpha) ", and click on the button “Use VirtualBox”, it does a big messm it deletes the default machine and never ends.
Thanks for your help

Can somebody please respond by something so this threaad can be closed and we stop using Kitematic

Is Kitematic abandoned, is there somebody following developers in this forum?

I am more concerned that with such a large community, this comment has gone unanswered for so long.
Why? Because, one, it has 470 views for a reason…like it has happened more than one; and two, I also received the same message. Of course this is just a Windows issue, and had I been running Ubuntu, I probably would not have had this, but I am and I am.

Point is, can someone address this question please, and thank you, in advance.

Same here…
i followed the trail on https://docs.docker.com/docker-for-windows/
new install on Windows 10 Home with VM VirtualBox Versie 5.1.10 r112026 (Qt5.6.2)
hello world went fine :slight_smile:
nginx installed fine but could not connect to localhost… :unamused:
kitematic loads to about 51% and then Error: connect ENOENT //./pipe/docker_engine :anguished:

PS: I also have VM Workstation 12 pro installed which works
hope that anyone came across this, solved it and would like to share… :wink: