Error invoking remote method 'desktop-go-backend' after software update

After doing a software update to 4.9.1, my docker desktop could not run and quits itself. I managed to capture an error that says “error invoking remote method 'desktop-go-backend”. After repeatedly running docker desktop to see the information.

I uninstalled docker desktop, re-installed with the previous version and it was okay. Did the software update again and the issue repeated.

I’m running it in Windows Server 2019.

Any solution to this?

I saw many times on this forum that people install Docker Desktop on Windows Server, but I never saw statement from Docker Inc that it would be supported. Can you show where you read that?

Docker / Frequently asked questions / How do I run Windows containers on Windows Server?

If it worked for you, then either the documentation is outdated or it worked for some reason without support and the last update broke it since Docker Inc did not focus on the Windows Server compatibility due to the lack of support.

I can check later if it happens on my Windows 11, but until that you can read about similar issues since it also happened on MacOS too

Search for the error message to find more issues. I hope some of them can help if I we can’t. You can also join the conversation in one of the issues on GitHub or create a new one if you think it is a different issue.

Thank you for the reply and information. I decided I could use it on Windows Server because it supports for hyperv and containers.

I came across the same info from github you linked before posting. I could not even pass Settings, to get to > Resources > Disk Image Location. When Docker dashboard appears, I clicked on Settings, the error banner comes out at the top briefly and Docker fully quits itself (application closed).
By the way, the error I saw did not had the additional text = :Error “no such file or directory”. Only displayed as my post title.

So in other words, I am not able to change anything from the dashboard/UI as it force quits. I have to change some parameters from a json or other editable file before running Docker Desktop for it work.

Anyway, I guess this ticket will reach its end here as Windows Server is actually not supported for Docker Desktop.

Thanks for the time.

On windows 10, with client:

Cloud integration: v1.0.25
Version: 20.10.16
API version: 1.41
Go version: go1.17.10
Git commit: aa7e414
Built: Thu May 12 09:17:07 2022
OS/Arch: windows/amd64
Context: default
Experimental: true

I remove some folders from %appdata% directory and docker works. Below we can see an image showing such folders.

1 Like

@bybitden, since you explicitly responded to Ákos’ June 18th post, which is mainly about installing on Windows Server: what are you trying to tell us with this screenshot?

Aside, the error message is slightly different, lacking the word go in desktop-go-backend. For search and all, which don’t like images:

Error invoking remote method 'desktop-backend': [object Object]

1 Like

I tried all these methods above but they seemed not to work but here is what i did .
I went to the docker icon in my taskbar (or it could be in the hidden icon section located in your taskbar) .
<right click on the icon
<click on switch to linux containers
<restart docker or your pc
Everything works fine .
You woulnot keep seeing the prolonged docker desktop starting message or any error which will lead you to doing some diagnosis checks.
You can still run diagnosis checks on it again if you want.