Request returned Internal Server Error for API route and version, check if the server supports the requested API version

Hi,

I installed Docker Desktop and this is my docker info and version:

I installed few camunda containers on docker and when I am trying to browse using localhost url I am getting this error -

“request returned Internal Server Error for API route and version http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.45/containers/71318481746a3d8b5cf87698223c264e1855e434493201466ee9323dc9bfaaa3/json, check if the server supports the requested API version”

Even if you check the screenshot, after entering the command, its printing that error before showing the actual result.

This error is not specific to the container but something to do with Docker Engine version and Docker API version compatibility. I checked the documentation and the compatibility looks fine.

I checked few topics on docker forum [Docker Desktop Fails to Start Daemon · Issue #156 · docker/desktop-linux · GitHub] and tried enabling the “Use containerid for pulling and storing images” in SETTINGS/GENERAL but no luck.

What could be the cause of this issue? Can someone from the community help me with this, please ?

Did you install any similar software like Podman Desktop. did you have a previous Docker Desktop which could be incorrectly uninstalled?

Please try the following command and check if you can see more contexts besides “default”, “desktop-linux”, “desktop-winodws”.

docker context ls

No, I did not install Podman Desktop.
After running the command, this is what I see:

I am new to Docker so I did a lot of trial and error as explained below:

I installed Docker Desktop for the first time but before the docker engine started running correctly, I had to do multiple reinstallation to make it work.

Earlier when I ran the installation on Windows 10 OS, it wasn’t working but when I upgraded to Windows 11, I used the same exe which did not work either.

Then I downloaded exe for Windows 11 and at last after multiple reinstallation, it worked only when I unchecked “use wsl2 instead of Hyper-v”.

Try to follow this guide to completely uninstall Docker Desktop

And install it again.

I don’t use it often, but I always install the WSL2-based Docker Desktop. It has different requirement than the Hyper-V backend, but usually it has better performance or at least have options to achieve better performance. If you can’t make it work with the HyperV backend, I recommend trying the WSL2 backend again. Just make sure you enabled the required Windows Features.

I uninstalled docker and WSL.
Turned off below windows features:

  1. Hyper-V
  2. Virtual Machine Platform
  3. Windows HyperVisor Platform
  4. Windows SubSystem for Linux

Rebooted.

Turned on the above windows feature and installed Ubuntu 22.04.3 LTS from Microsoft Store.
Installed Docker Desktop with use wsl2 instead of Hyper-v

Rebooted.

But its still not working.

I get this error after launching Docker Desktop:

deploying WSL2 distributions
provisioning docker WSL distros: ensuring main distro is deployed: deploying "docker-desktop": importing WSL distro "The specified service does not exist as an installed service. \r\nError code: Wsl/ERROR_SERVICE_DOES_NOT_EXIST\r\n" output="docker-desktop": exit code: 4294967295: running WSL command wsl.exe C:\WINDOWS\System32\wsl.exe --import docker-desktop <HOME>\AppData\Local\Docker\wsl\main C:\Program Files\Docker\Docker\resources\wsl\wsl-bootstrap.tar --version 2: The specified service does not exist as an installed service. 
Error code: Wsl/ERROR_SERVICE_DOES_NOT_EXIST
: exit status 0xffffffff
checking if isocache exists: CreateFile \\wsl$\docker-desktop-data\isocache\: The network name cannot be found. 

Also, when I checked wsl version by executing below command:

wsl --list --verbose

I am running into below error:
image