Docker Community Forums

Share and learn in the Docker community.

Error login in, searching images anything related to internet

(Dmikov) #1

Expected behavior

to be able to connect to docker hub

Actual behavior

$ docker login
Login with your Docker ID to push and pull images from Docker Hub. If you don’t have a Docker ID, head over to to create one.
Username: dmikov
Error response from daemon: Get dial tcp: lookup on read udp> i/o timeout


Docker version 1.12.0-rc2, build 906eacd, experimental
A diagnostic was uploaded with id: 4506EFBA-EB3F-4694-AC0E-699EBE15121A/2016-06-21_10-33-17
Windows 10

Steps to reproduce the behavior

  1. Run login command

(Pedro Henrique) #2

Same here. The Virtual machine cant connect with the internet. I had tried to factory reset even reinstall all hyper-v features and nothing

Docker login: Dial tcp: lookup read udp i/o timeout
(Dave) #3

Make an interface on virtual interfaces Hyper-V take it on external interface (Wi-fi, eth0 or something) and Add interface for this connection to Hyper-V MobiLinuxVM - and all will work!

(Pedro Henrique) #4

yes but my VM will be exposed to outside connection

(Dave) #5

Yep. I making it before my try with virtual adapters

(Dave) #6

Machine Settings

(Dave) #7

Sorry for russian language in settings
Problem was in acces v-machine to internet - that way you are forward packets from interfaces

(Pedro Henrique) #8

That solution solve 1 problem but create one exposing the machine in the network

(Dave) #9

So i tried other solutions and have no found way to get acces to internet from machine. Best regards.