Docker Community Forums

Share and learn in the Docker community.

Error response from daemon: Get Proxy Authentication Required

Good morning I am starting with a docker on a RED HAT 8 server, but I am having problems to make the docker run hello work, I get the following error:

Unable to find image ‘hello-world:latest’ locally
docker: Error response from daemon: Get Proxy Authentication Required.
See ‘docker run --help’.

Same when I’m going to login

[root@srvdevrma1 ~]# docker login
Login with your Docker ID to push and pull images from Docker Hub. If you don’t have a Docker ID, head over to to create one.
Username: cesarjv
Error response from daemon: Get Proxy Authentication Required
[root@srvdevrma1 ~]#

Configure my proxy:

[root@srvdevrma1 ~]# echo $http_proxy

[root@srvdevrma1 ~]# echo $https_proxy

[root@srvdevrma1 ~]# cat /etc/apt/apt.conf.d/proxy.conf
Acquire::http::Proxy “http://E10697:xxxxxx++@”;
Acquire::https::Proxy “http://E10697:xxxxxx++@”;

[root@srvdevrma1 ~]# cat /etc/systemd/system/docker.service.d/http-proxy.conf

Where can I be failing?

@cesarjv Did you find a way for this issue?

Here are few suggestions:

Try restarting your Docker service.
Check your network connections. For example by the following shell commands:

</dev/tcp/ && echo Works || echo Problem
curl && echo Works || echo Problem
Check your proxy settings (e.g. in /etc/default/docker).

If above won’t help, this could be a temporary issue with the Docker services (as per Service Unavailable).

Related: GH-842 - 503 Service Unavailable at

I had this problem for past days, it just worked after that.

You can consider raising the issue at docker/hub-feedback repo, check at, Docker Community Forums, or contact Docker Support directly.