Docker Community Forums

Share and learn in the Docker community.

Error response from daemon: Get https://registry-1.docker.io/v2/

docker

(Pythonsynapse) #21

I also had the same issue i tried removing all the firewalls to make it work. and yes it worked but is there any way by which i can just add some exceptions to the firewall?


(Afreeland) #22

I was seeing this issue on Windows Server 2016, with firewall temporarily off and community 17.10.0-ce-win36 (13788). I needed to disable ‘Experimental features’ for another complication and once I did that docker automatically restarted. I opened up an admin PowerShell prompt and used docker login and tried docker pull again and it worked.


(Kaiyulee) #23

Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:59679->[::1]:53: read: connection refused

Restart Docker resolved this issue.


(Neethuabacker) #24

This worked for me , thank you!


(Sumanta1985) #25

Restart Docker resolved the issue.


(Bashamer) #26

disable experimental features + restart did the trick for me.


(Feradz) #27

Restarting the docker resolved this problem for me.


(Mbjelacfinsec) #28

this is the trick. no account or login required.


(Edipojs) #29

Boa tarde,
Tentei quase todas as coisa que foram mencionadas aqui, porém o que resolveu meu problema foi

  • 1ª Removi a versão estável do docker (no meu caso a versão 17.03)
  • 2ª Exclui a pasta .docker ( C:\Users{nome do usuário}.docker )
  • 3ª Reiniciei o sistema operacional
  • 4ª Instalei a versão edge do docker
    ( https://store.docker.com/editions/community/docker-ce-desktop-windows -
    Get Docker CE for Windows (Edge) )
  • 5ª Reiniciei novamente o sistema operacional

Aqui funcionou dessa forma!
*Observação: tentei remover a pasta “.docker” e instalar a mesma versão(17.03), mais não funcionou.

thanks!


(Adithya1894) #30

I had the exact same Issue and it was resolved, when I restarted the Docker deamon.


(Boral) #31

Creating an account at Docker hub solves the issue.


(Jdbtee) #32

I had same issue on Mac at first run, every time I tried to use the CLI a similar error came up, to solve just log into docker from the shell:

`Docker login’

Then enter your $Username and $password


(Judsondocker619) #33

I have changed dns server to fixed 8.8.8.8 and also restarted docker still im getting error
Error response from daemon: Get https://registry-1.docker.io/v2/realm/realm-object-server/manifests/latest: net/http: TLS handshake timeout
please help me with this


(Laurie0131) #34

I type the following docker command:

C:\temp\Docker>docker pull store/gitpitch/desktop:personal

And I get the following ERROR Message:

Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: requ est canceled while waiting for connection (Client.Timeout exceeded while awaitin g headers)

I tried the Test with “Hello world” with the following docker command:

C:\Program Files\Docker\Docker>docker run hello-world

Get error message:

Unable to find image ‘hello-world:latest’ locally
docker: Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exc eeded while awaiting headers).
See ‘docker run --help’.

Docker version:
C:\Program Files\Docker\Docker>docker --version
Docker version 18.03.0-ce, build 0520e24


(Artisticcheese) #35

Try Invoke-WebRequest https://registry-1.docker.io/v2/ from powershell


(Ktquez) #36

Change your DNS (Google, openDNS and others)

When I did it worked.


(Ghaegdorens) #37

I had the problem with a ubuntu hyper-V virtual machine. I added the dns-servername 8.8.8.8 and dns-servername 8.8.4.4 to the /etc/network/interfaces and rebooted. That solved the issue for me.


(Shivabasayya) #38

Thanks, I face this issue from corporate network. need to try from home network.