Docker Community Forums

Share and learn in the Docker community.

Error response from daemon: Get https://registry-1.docker.io/v2/

docker

(Montaro) #41

Great answer, worked for me!
Thanks!


(Basithsyed) #42

I am having same issue too. Any assistance would be highly appreciated.


(Krikri90) #43

I have changed DNS to 8.8.8.8 and also changed to company proxy,. Still I am getting same error.


(Gongkunjxl) #44

You are right. Use you username not email, eg: jack@qq.com use jack


(Sanutopia) #45

Hello Friends,

I have windows 7 Ent and there I have installed docker. But when I am running docker command “docker run hello-world” it is giving the same error.
“Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled”

I have tried almost all options mentioned in this chain of discussion. But none of them has resolved the problem.
Also, when I am executing “docker-machine” it is giving error : “sh: docker-machine: not found”.
Please suggest how to resolve this and docker run an image successfully.

Thanking you
Santanu


(Jofumera) #46

i can’t type-in my password at the console, thy is that?

Thanks


(George Johnson) #47

A word of warning, be very, very careful of copying and pasting. I just spent 2 hours trying to solve this problem with a proxy server only to realise I had a single quote on one end of the proxy string and a double quote at the other end! ( Doofus! )

This command showed me the proxy setting was coming up, so I scanned every character in my http-proxy.conf file until I found the problem.

systemctl show --property=Environment docker


(Aiapps) #48

Thanks dude, it works for me in a Windows 10 Home edition. Very helpful :slight_smile:


(Nooshnabi) #49

Thanks for the info. It worked for me!


(Amitgupta3) #50

This works. I spent lot of time in this.


(Fzoccara) #51

This steps work for me as well!


(Marneylc) #52

Unplug and plug it back in!


#53

Worked for me as well. Thanks


#54

I am using Docker Desktop v2.0.0.0 with engine 18.09.0 on Windows 10. I restarted Docker Desktop and the problem solved.


#55

awesome! It works for me!


#56

Still facing below exception
root@block1-VirtualBox:~# docker pull hello-world
Using default tag: latest
Error response from daemon: Get https://registry-1.docker.io/v2/: x509: certificate signed by unknown authority

Please help to resolve the issue


#57

Hello. How did you do it? Did you just disable the Windows’ Firewall? If not, can you provide some steps to accomplish it? Thanks!