Docker Community Forums

Share and learn in the Docker community.

Error: Unable to remove filesystem for ... device or resource busy


(Stéphane Klein) #1

On all my Debian Server, I’ve frequently this error:

# docker-compose up -d
Removing gitlab_gitlab
gitlab_redis is up-to-date
gitlab_postgresql is up-to-date
Recreating 015ae5304b6d_gitlab_gitlab

ERROR: for gitlab  Unable to remove filesystem for 015ae5304b6dc83da84d612b40e4743c6bfffbd77018fa44d9df4ac4d5e05b50: remove /var/lib/docker/containers/015ae5304b6dc83da84d612b40e4743c6bfffbd77018fa44d9df4ac4d5e05b50/shm: device or resource busy
ERROR: Encountered errors while bringing up the project.

Versions:

# cat /etc/debian_version
8.6
# docker version
Client:
 Version:      1.12.3
 API version:  1.24
 Go version:   go1.6.3
 Git commit:   6b644ec
 Built:        Wed Oct 26 21:39:14 2016
 OS/Arch:      linux/amd64

Server:
 Version:      1.12.3
 API version:  1.24
 Go version:   go1.6.3
 Git commit:   6b644ec
 Built:        Wed Oct 26 21:39:14 2016
 OS/Arch:      linux/amd64

How can I fix this issue?

Best regards,
Stéphane


(Stéphane Klein) #2

Some issue about this error message:


(Stéphane Klein) #3
# docker version
Client:
 Version:      1.12.3
 API version:  1.24
 Go version:   go1.6.3
 Git commit:   6b644ec
 Built:        Wed Oct 26 21:39:14 2016
 OS/Arch:      linux/amd64

Server:
 Version:      1.12.3
 API version:  1.24
 Go version:   go1.6.3
 Git commit:   6b644ec
 Built:        Wed Oct 26 21:39:14 2016
 OS/Arch:      linux/amd64
root@santa-maria:~/docker-gitlab# docker info
Containers: 19
 Running: 14
 Paused: 0
 Stopped: 5
Images: 117
Server Version: 1.12.3
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 433
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: null host overlay bridge
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options:
Kernel Version: 3.16.0-4-amd64
Operating System: Debian GNU/Linux 8 (jessie)
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 7.788 GiB
Name: santa-maria
ID: ESM4:TQUX:YEER:AJMK:T4FZ:SO62:WK2Q:HLEQ:43VQ:AEII:BVQ3:6JCF
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No kernel memory limit support
WARNING: No oom kill disable support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
Insecure Registries:
 127.0.0.0/8

(Taylor Patton) #4

I’ve tried various umounting steps from solutions I’ve found from the internet but only way I’ve been able to solve this issue myself was server reboot.


(Loomchild) #5

I have the same issue since a few weeks, also when using

docker-compose up -d

(Stéphane Klein) #6

It is same error? http://blog.hashbangbash.com/2014/11/docker-devicemapper-fix-for-device-or-resource-busy-ebusy/


(Stéphane Klein) #7

I think is that: https://github.com/google/cadvisor/issues/771


(Stéphane Klein) #8

Fixed, the problem is Cadvisor