Docker Community Forums

Share and learn in the Docker community.

Error when installing docker on a Ubuntu 16.04 VPS


(Cjorgens) #1

Hello everybody, I am a new to this forum and to Docker in general.

I am currently trying to install Docker on a Ubuntu 16.04 64-bit VPS hosted by RamNode

I am having an error message trying to install the Docker package:
(I used apt-get update, rebooted multiple times, tried using the “wget -qO- https://get.docker.com/ | sh” command with the same results.)

$ sudo apt-get install docker-ce
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  docker-ce
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/30.2 MB of archives.
After this operation, 149 MB of additional disk space will be used.
Selecting previously unselected package docker-ce.
(Reading database ... 54007 files and directories currently installed.)
Preparing to unpack .../docker-ce_17.12.0~ce-0~ubuntu_amd64.deb ...
Unpacking docker-ce (17.12.0~ce-0~ubuntu) ...
Processing triggers for systemd (229-4ubuntu21) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up docker-ce (17.12.0~ce-0~ubuntu) ...
Job for docker.service failed because the control process exited with error code                                        . See "systemctl status docker.service" and "journalctl -xe" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: e                                        nabled)
   Active: activating (auto-restart) (Result: exit-code) since Fri 2017-12-29 12                                        :24:00 EST; 9ms ago
     Docs: https://docs.docker.com
  Process: 1321 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=1/FAILU                                        RE)
 Main PID: 1321 (code=exited, status=1/FAILURE)

Dec 29 12:24:00 horferos systemd[1]: Failed to start Docker Application Con...e.
Dec 29 12:24:00 horferos systemd[1]: docker.service: Unit entered failed state.
Dec 29 12:24:00 horferos systemd[1]: docker.service: Failed with result 'ex...'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package docker-ce (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 docker-ce
E: Sub-process /usr/bin/dpkg returned an error code (1)

I could not find a similar issue on the forum, but I must admit I am not the best at solution-hunting.

Would anyone have a suggestion ?
Thanks


(Cjorgens) #2

I solved my problem by switching from an OpenVZ VPS to a KVM VPS after finding https://twitter.com/ramnode/status/642090930854567937?lang=fr
Seems to be working fine !