Docker Community Forums

Share and learn in the Docker community.

Errore in bash while running docker

docker

(Jokerigno) #1

Hi all

I created my first docker (based on one found in hub) but if i wan to ssh it i creceive an errore (the same error appers in the original docker image):

rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused “process_linux.go:87: adding pid 22700 to cgroups caused “failed to write 22700 to cgroup.procs: write /sys/fs/cgroup/systemd/docker/54cce0e5155bfc766e8a33f4faf6c52911ae78bbecdf215835389e25d1a70003/cgroup.procs: no space left on device””

can someone please support me?

below the docker file content

FROM ubuntu:16.04
RUN  apt-get update
RUN  apt-get install -y \
     wget
	 RUN  wget -q -O - https://apt.mopidy.com/mopidy.gpg | apt-key add -
	 RUN  wget -q -O /etc/apt/sources.list.d/mopidy.list https://apt.mopidy.com/jessie.list
	 RUN  apt-get update
	 RUN  apt-get install -y \
	      python-pip mopidy
		  RUN  apt-get remove -y python-pyasn1
		  RUN  pip install Mopidy-Scrobbler Mopidy-Moped Mopidy-GMusic Mopidy-Party Mopidy-Iris Mopidy-Mopify

		  COPY mopidy.conf /root/.config/mopidy_default.conf
		  COPY mopidy.sh /usr/local/bin/mopidy.sh

		  EXPOSE 6600 6680
		  ENTRYPOINT ["/usr/local/bin/mopidy.sh"]

Thank you in advance!


(Sam) #2

seems like you have run out of space


(Jokerigno) #3

This was my first thought but the volume in which docker is installed has a lot of space, and the other containers don’t show the same message.

How can I fix it?


(Jokerigno) #4

Update:

I ran

docker system prune -a

but the issue is still there (also if I have 786 GB free).


(Sam) #5

i do not know myself… but it looks like a config issue…

/sys/fs/cgroup/systemd/docker/54cce0e5155bfc766e8a33f4faf6c52911ae78bbecdf215835389e25d1a70003/cgroup.procs

http://man7.org/linux/man-pages/man7/cgroups.7.html


(Jokerigno) #6

And I think I’m not the only one facing this issue!

https://github.com/moby/moby/issues/29638


(Sam) #7

yep, looks like a bug… others have worked around by rebooting the docker host


(Jokerigno) #8

I tried rebooting my Synology NAS. Nothing changed :frowning: