Docker Community Forums

Share and learn in the Docker community.

Escaping special characters powershell Dockerfile

I’m trying to update a splunk config in my Dockerfile using the below:

RUN Add-Content ‘C:\Program Files\SplunkUniversalForwarder\etc\system\local\deploymentclient.conf’ “clientName = dotnet-${env:APP_NAME}”

This works fine if I run it directly in the container, but bombs out with " A positional parameter cannot be found that accepts argument ‘=’. " I’ve tried escaping the “=” a few different ways but no luck?
Any one got any ideas?

Running on Windows 2019 Data center edition.