Docker Community Forums

Share and learn in the Docker community.

Exports seems to be a protected word in COPY

My Dockerfile

FROM jboss/keycloak:9.0.3
WORKDIR /opt/jboss/
COPY exports /opt/jboss/keycloak/exports

Te result

 => ERROR [3/3] COPY exports /opt/jboss/keycloak/exports                                                                                                                                                                                                             0.0s
------
 > [3/3] COPY exports /opt/jboss/keycloak/exports:
------
failed to compute cache key: "/exports" not found: not found

After several hours of searching for a solution I tried to rename exports to export and the copy worked without any problems.

COPY exports /opt/jboss/keycloak/export
Work

COPY export /opt/jboss/keycloak/export
Work

Docker engine: 20.10.5
Docer desktop: 3.3.1 (63152)

Follow these simple steps to do it: Step 1: Open the Microsoft Word document that you want to unprotect and then click on “File” and select “Protect Document” under the section marked “Info”. Step 2: In the drop-down menu, select “Encrypt with Password” and then remove the password from the password field. Click “OK”.