Docker Community Forums

Share and learn in the Docker community.

Fail to reproduce Docker for AWS Demo (Public Beta)

Expected behavior

I want to spin up a Docker swarm of 5 servers on AWS using the procedure (and settings) shown on the demo YouTube-video:

Actual behavior

The CloudFormation gets a (timeout?) fail after 20 min. at the AutoScalingGroup step + then executes a rollback. (see the attached screenshot)

Additional Information

I’ve tried it multiple times with same result.
I’m using an AWS free tier account.
It’s the first EC2 instances I (try to) spin up on this account.
My EC2 service should be active (=I have received the “Dear AWS Customer, We would like to notify you that now you can launch Elastic Compute Cloud (EC2) instances in all available AWS regions. Sincerely, Amazon Web Services” mail from Amazon.)

Steps to reproduce the behavior

Follow the procedure shown on the Docker for AWS Demo (Public Beta) video.

Question

What am I doing wrong – and what should I do to correct the issue?

Screenshot

We have seen this before for some people with the AWS free tier, we are not exactly sure what causes this. If you start up the stack and then go to the auto scaling group on the EC2 dashboard, and then look at the events on the Autoscale group (while cloudformation is starting up), it might give you some more information. One cause would be that you are over your instance limit. For example, If you are only allowed 5, but you are trying to start 6, etc.

Another possible cause is the lack of permissions, but I don’t think that is the issue in this case.

Try that, and let us know if you find out any more information.

Hi Ken

Thanks for the tip.
:slight_smile:

When looking in the auto scaling group on the EC2 Dashboard I get the following info regarding the fail reason:
“Status Reason: This account is currently blocked and not recognized as a valid account. Please contact aws-verification@amazon.com if you have questions. Launching EC2 instance failed.”

My auto scaling instance limit is currently set to 20, so that should not be the issue.

Next step:
I’ll try to contact AWS via the specified mail address (but I don’t set my hopes high on getting any answer, as I belive the AWS free tier is generally supplied without any kind of customer support.)

Or do you have any other suggestions on how to proceed?

Niels

Screenshot: