Docker Community Forums

Share and learn in the Docker community.

Failed to solve with frontend dockerfile.v0: failed to read dockerfile: error from sender: resolve : EvalSymlinks: too many links

I tried many different suggestions from my Google searches to try to solve this. Restarting, VSCode, Restarting DockerDesktop, setting a bunch of different options and so on.

Environment:

  1. Windows 10 Pro - 20H2 - 19042.985 - Windows Feature Experience Pack 120.2212.2020.0

2: Using WSL

The Docker image would build if I ran the “docker build …” command, just not under docker-compose

I finally decided to take the message at it’s face value for this clause “EvalSymlinks: too many links”.

When my SSD filled up, I bought a new bigger one (an upgrade from a 256Gig to a 1TB drive. So, I said to myself, what do I do with this old drive now? Myself answered me, use it. Well, I have gotten tired of changing drives over the years and I thought to myself, why not use the Linux type mounting that I’ve starting using in Linux.

Hey, good idea I said to myself. So, I mounted the old SSD to a Workspace Folder under my c:\Users\Tom.corp folder. Life was good, I had plenty of space now.

That is until I tried to use “docker-compose up” on my project. Then I got that error message.

THE FIX:
When I moved the project folder from the mounted drive to a new testWorkspace folder on the base drive, the docker-compose command would run. It seems that the “docker-compose” command does not like even 1 symlink.

FYI: Just to test it, I copied it back to the mounted drive and it failed to build with the same message.