Docker Community Forums

Share and learn in the Docker community.

FATA[0005] Error pushing to registry: Authentication is required


(Gmeans) #1

I’ve been unable to push an image to the registry all day due to the following failure:

FATA[0005] Error pushing to registry: Authentication is required.

My docker hub account has been authenticated successfully, but the client asks me to log in prior to push. I enter my credentials, and get “Login Succeeded”, then I see the error above.

I’ve checked the DockerHub status page and everything says operational but I’ve also noticed builds taking forever.

Is there an issue with the registry?

Docker version 1.6.2, build 7c8fca2


(Sabin Basyal) #2

For this error, are you trying to manually push to an Automated Build repository?


(Gmeans) #3

At first I tried pushing to an automated build, but that was because our builds were showing pending for an hour so I was trying to get something up there. After the error, I created a regular repo and tried pushing to it and received the same error.

This morning, however, pushing to the manual repo appears to be working again. So I’m guessing this has to do with the Authentication issues others mentioned yesterday.

If a repo is set up as an automated build, is it not possible to push manually built versions to it?


(Sabin Basyal) #4

You got it right. It is not possible to push manually to an Automated Build repository.
Other than that, the long Pending status was due to high volume of builds, that your build has to wait for resources.


(Gmeans) #5

While from a technical standpoint I understand the waiting for resources thing, from a business standpoint Dockerhub’s reliability leaves a lot to be desired.

We’ve been in a few situations where we needed to get a dependency updated, only to have Dockerhub be down or having to wait an hour for a build to process. These are on private images as well under a paid organization account.

And as you confirmed, if we are in that situation we have no choice but to wait since automated builds don’t allow manual pushes (which are also incredibly slow).

At this point quay.io is a better choice since their build pipeline appears to be more reliable and they offer the same (actually more) features than DockerHub including automated builds from git repos. It would be great if you offered organization accounts the option to have their own build host and enable build caching.


(Sabin Basyal) #6

Thank you for the suggestion. We can totally understand your problem and we are indeed working on this, to make it better.


(Nigel Harniman) #7

I have the same error

FATA[0005] Error pushing to registry: Authentication is required.

The repository used to be configured as an Automated Build Repository.

I deleted the repository and re-created it. I still get this error.

Does deleting a repository fully delete it, or does it leave some Automated Build config around?

FWIW I have renamed the repository in the Dockerfile and pushed to a new repository and it works fine - i’d just like to re-use the existing repo as a non-Automated Build one.

Any ideas?


(Adam Giemza) #8

Same issue here. I deleted the automated build repo and created a manual one and cannot push to it. Maybe the servers need to “realize” it first somehow after a timeout?

I will try tomorrow again, otherwise I have to rename the repo.


(Sabin Basyal) #9

@harniman: This was different issue because of some lag in permission database. I checked on your repository and it looks fine.
@deradam: Same reason for you, but since your’s is manual build now, I am not sure if things are working for you or not.