Docker Community Forums

Share and learn in the Docker community.

Automated Build Failing - "authentication required"


(Andrew Dunham) #1

Hi there,

I’m getting an “authentication required” error with an automated build of mine - any idea what’s up with that, and how I can fix it?

See the build here: https://registry.hub.docker.com/u/andrewd/musl-cross/build_id/68431/code/bkqfckaopyfbtmnf7yarsgh/

The particular error is: Error pushing to registry: Authentication is required.

Thanks!
–Andrew


(Andlaz) #2

+1, getting the same error

nothing else suspicious in logs, everything builds fine, i’m seeing “Error pushing to registry: Authentication is required.” on the “Error” line on the build page.

thanks,
A


(Andlaz) #3

Second job i started ( no changes to image ) completed fine just now.


(Jakirkham) #4

+1 Exact same problem. Have an automated build based off a public GitHub repo that completes the build successfully. However, after building it errors with this status “Error pushing to registry: Authentication is required.”. This problem did not exist a month ago so clearly a bug has crept into code.


(Jakirkham) #5

Also, restarted the job from Docker Hub to no effect.


(Jakirkham) #6

As this problem has been going on for at least half a day can someone let us know if anyone is looking into this at least. Thanks.


(Kgorskowski) #7

+1 Same problem here. Manual pushed worked finde, delete the repo and created an automated build - authentication required error occurs


(Andy Rothfusz) #8

Hello,

Sorry about this issue – we’re checking into it and will update the status here:
http://status.docker.com/pages/incident/533c6539221ae15e3f000031/5581f9fabdcd5cfa0d00027f

/Andy


(Andrew Dunham) #9

Hi Andy,

Thanks for the update. The status page shows that the problem has been fixed, but this build that I just ran failed with the same error.

Thanks,
–Andrew


(Tyler Erickson) #10

I am also currently receiving the “Error pushing to registry: Authentication is required.” when building this repository: https://registry.hub.docker.com/u/tylere/docker-tmpnb-ee/


(Tyler Erickson) #11

The build succeeded on the fourth try, so I guess the authentication error was transient. Weird.