Docker Community Forums

Share and learn in the Docker community.

FIXED: Systemerror 1332 when trying to mount C drive


(Wimulkemanwebstores) #1

Expected behavior

The C drive should be a shared mount available to the docker VM.

Actual behavior

Docker is working, and I can create containers with a docker-compose command, but the mounted files aren’t available in the Docker VM.

Information

System: Windows 10 Pro
Docker version: 1.11.0

  • By default the C drive wasn’t shared in Docker. So I tried to enable this by going to Docker settings > click “Manage shared drives” > check C drive > click Ok.
  • On clicking Ok I recieve a challenge for my credentials. When I enter the credentials but keep “Remeber credentials” unchecked, the window closes. In the logs I see that the share could bot be made because there where no credentials given.
  • When I enter my credentials and check the “Remember credentials” box, the challenge for credentials keeps popping up. In the logs I see the following error:

[10:53:59.988][Auth ][Info ] Storing credentials: myusername:***********
[10:53:59.998][Auth ][Info ] Retrieved credentials: myusername:***********
[10:54:00.034][SmbShare ][Info ] “C” is not shared
[10:54:00.037][SmbShare ][Info ] Sharing “C:” as “C”
[10:54:00.041][SmbShare ][Info ] Creating share C with Full Control to wimulkeman
[10:54:00.070][SmbShare ][Error ] Creating share failed with code 2: Systeemfout 1332.

Er is geen toewijzing uitgevoerd tussen accountnamen en beveiligings-id’s.

[10:54:00.097][SmbShare ][Info ] “C” is not shared

The error seems to be a system error 1332 from Windows. https://msdn.microsoft.com/en-us/library/windows/desktop/ms681385(v=vs.85).aspx

Steps to reproduce the behavior


(Wimulkemanwebstores) #2

The problem for me was a chaged local Windows username.

In my case, it first was userA, but I changed it to userB in the course of time. For the authentication in Docker I tried to user userB as username, but that failed. After entering userA as username, Docker was able to create the mount for the correct user.