GCR / Google Artifact Registry credHelper issues with Mac Docker Desktop

Version: 24.0.6, build ed223bc
Mac OS X Version: Latest Sonoma

I’m having some issues getting either of the methods for authenticating either GCP Artifact Registry or GCR using either of the two typical methods (either the gcloud CLI with gcloud auth configure-docker, or % docker-credential-gcr configure-docker -include-artifact-registry) to allow me to push to Artifact Registry or GCR using Mac Docker. While I understand these are via third party tools, running docker push with -D or -l debug isn’t giving me any additional information on what it’s trying to do when
using those plugins. The failure is more or less immediate.

I’ve tried using the same commands from a Linux workstation, and it works fine. Is there any way to get additional debugging information on why Docker is either not using, or getting some kind of failure from, the gcloud helper?

I’ve used these methods successfully in the past on other machines / with older versions of Docker desktop.

% docker push us.gcr.io/project/image
d119a99eb236: Waiting 
failed to authorize: failed to fetch anonymous token: unexpected status from GET request to https://us.gcr.io/v2/token?scope=repository%3Aproject%2Fimage%3Apull%2Cpush&scope=repository%3Aproject%2Fimage%3Apush%2Cpull&service=us.gcr.io: 401 Unauthorized
## or artifact registry
% docker push us-docker.pkg.dev/project/repo/image
Using default tag: latest
The push refers to repository [us-docker.pkg.dev/project/repo/image]
failed to authorize: failed to fetch anonymous token: unexpected status from GET request to https://us-docker.pkg.dev/v2/token?scope=repository%3Aproject%2Frepo%2Fimage%3Apull&scope=repository%3Aproject%2Frepo%2Fimage%3Apull%2Cpush&service=us-docker.pkg.dev: 403 Forbidden


	"auths": {},
	"credsStore": "desktop",
	"credHelpers": {
		"asia.gcr.io": "gcloud",
		"eu.gcr.io": "gcloud",
		"gcr.io": "gcloud",
		"marketplace.gcr.io": "gcloud",
		"staging-k8s.gcr.io": "gcloud",
		"us-docker.pkg.dev": "gcloud",
		"us.gcr.io": "gcloud"
	"currentContext": "desktop-linux"

(it will say gcr when using the other plugin, but that doesn’t work for me either; I also tried temporarily updating the gcloud bit to the full path of the gcloud binary to see if that helped).