Docker build fails to pull GCR image while docker pull succeeds

I’m seeing a strange issue where I can pull the latest image from a repository in Google Container Registry, but if I try and docker build a Dockerfile that has the FROM directive identical to what I’m succesfully docker pull-ing it fails. I can work around this by pulling before I build, but I would really prefer not to. Any ideas why this could be an issue? I’ve tried logging out and back in to gcloud and re-authorizing but I get the same error no matter if I’m logged in or out:

denied: Permission denied for "latest" from request "/v2/-------/--------/manifests/latest".

This is only happening in docker for mac. Running inside an ubuntu docker image everything works as expected

I think this is a bug because I’m not seeing this behavior on linux.

I am seeing this issue too. I imagine it is specific to google cloud, rather than Docker, but would be interested to know if you resolved it. It seems to be very intermittent to me - and happens on a Ubuntu server, not a Mac.