Docker Community Forums

Share and learn in the Docker community.

Getting past proxy: Authentication required and proxyconnect tcp: EOF

I am behind a firewall. I am trying to access a linux docker image on windows to run a wordpress site.

I type docker-compose up

It says
Pulling mysql (mysql:5.7)
ERROR Get https://registry-1.docker.io/v2/: proxyconnect tcp: EOF

I try
curl https://registry-1.docker.io/v2/
And I get the error
{"errors":[{"code":"UNAUTHORIZED", "message": "authentication required". "detail":null}]}

I have set the proxy in docker desktop. I also set the proxy inside my dockerfile like this
ENV PROXY http://****:**
ENV http_proxy $PROXY
ENV https_proxy $PROXY
RUN curl -x $PROXY -o /bin/wp-cli.phar $WP_CLI_PHAR

In my wireshark capture I am getting the error message Error: STATUS_OBJECT_PATH_NOT_FOUND FOR mime.types, docker-credential-wincred.exe, and docker-credential-desktop

Would anyone be able to shed light on this? My network engineer is stumped.
OS: Windows 10 build 18363
App version: 46911

Solved! I was listing an https:*: but there was no https proxy! I changed both to web server and secure web server http and it works now.