Docker Community Forums

Share and learn in the Docker community.

Getting userland-proxy=false to work in Centos 7


(Kashrut) #1

am trying to install a mariadb instance in a docker container on Centos 7. It
actually works ok except all of the source addresses as seen by the
database are mapped to the internal virtual ip of the docker container
network. I have added “–userland-proxy=false” to the systemd startup
and “net.bridge.bridge-nf-call-iptables = 1” to
/etc/sysctl.d/99-sysctl.conf.

docker info returns:

Containers: 1
Running: 1
Paused: 0
Stopped: 0
Images: 11
Server Version: 1.10.3
Storage Driver: devicemapper
Pool Name: CentOS–7-docker–pool
Pool Blocksize: 524.3 kB
Base Device Size: 107.4 GB
Backing Filesystem: xfs
Data file:
Metadata file:
Data Space Used: 2.189 GB
Data Space Total: 89.21 GB
Data Space Available: 87.02 GB
Metadata Space Used: 589.8 kB
Metadata Space Total: 201.3 MB
Metadata Space Available: 200.7 MB
Udev Sync Supported: true
Deferred Removal Enabled: false
Deferred Deletion Enabled: false
Deferred Deleted Device Count: 0
Library Version: 1.02.107-RHEL7 (2016-06-09)
Execution Driver: native-0.2
Logging Driver: journald
Plugins:
Volume: local
Network: bridge null host
Kernel Version: 3.10.0-327.22.2.el7.x86_64
Operating System: CentOS Linux 7 (Core)
OSType: linux
Architecture: x86_64
Number of Docker Hooks: 2
CPUs: 4
Total Memory: 15.19 GiB
Name: xxxxxxxx.net
ID: 2ZAW:ULJP:JHAB:7F65:WSCX:S2AL:7B4H:VBMV:2WD2:2FE4:JBUY:IV34
Registries: docker.io (secure)


What am I missing?

Thanks