Docker Community Forums

Share and learn in the Docker community.

How to disable userland-proxy on OSX?


(Vignitin) #1

Hi,
I am running a mysql DB in a docker container on OSx. It works fine except that all of the source addresses as seen by the database are mapped to the internal virtual ip of the docker container network. How can I change this behavior to ensure the source IPs are not NAT’d? Reading threads on this topic, I understand that setting userland-proxy to false should solve this problem. How do I change this setting on OSX?

nitinvig-mbp:~ nitinvig$ docker info
Containers: 1
Running: 0
Paused: 0
Stopped: 1
Images: 3
Server Version: 1.12.0-rc2
Storage Driver: aufs
Root Dir: /var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 36
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host null overlay
Swarm: inactive
Runtimes: default
Default Runtime: default
Security Options: seccomp
Kernel Version: 4.4.14-moby
Operating System: Alpine Linux v3.4
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 3.857 GiB
Name: moby
ID: MCUK:46H3:DD2A:2PMF:OJRI:455H:ESSN:DIGJ:7FOM:XGNO:V3PU:4HJU
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
File Descriptors: 21
Goroutines: 28
System Time: 2016-09-03T04:21:04.963157237Z
EventsListeners: 1
No Proxy: *.local, 169.254/16
Registry: https://index.docker.io/v1/
Experimental: true
Insecure Registries:
127.0.0.0/8

Thanks,
Nitin