Hardware assisted virtualization and data execution protection

Hi all,

When I try to start Docker Desktop, I get this message which never appeared before:

“Hardware assisted virtualization and data execution protection must be enabled in the BIOS”

I read some other messages in this forum about this problem but none of the suggested solutions worked.

In the BIOS hyper virtualisation is enabled. I checked again in Task Manager and it also says “enabled”.

I didn’t change anything recently and suddenly I get this error message.

How can this be solved?

Thanks in advance for any reaction!

Check your firewall and antivirus in your system can block the connection, temporary disable them and then retry to start them.

Thanks for your reply.

I tried that: both together and apart, didn’t work.

Would be strange if it did, because I didn’t change anything and it has worked perfectly fine for months.

But, of course, it must have a “reason” for this error.

On what platorm? I can only guess that it is Windows as you mentioned Task Manager.It could be that the OS was updated automatically or I could imagine as hardware issue as well.

The OS is = Windows 11

The same way the problem appeared, out of nothing, the same way it went away… :slight_smile:

After a reboot (which I also tried earlier obviously), Docker works back like it used to.

Thanks both of you for the advice!!

Thank you for sharing this unexpected outcome. If you ever find out what it was caused by, please share it with us.