Unexpected error during startup

Hi when i start my docker i am getting this error.

“Hardware assisted virtualization and data execution protection must be enabled in the BIOS. See Logs and troubleshooting | Docker Documentation

Virtualization is already enabled

  1. BIOS.

  2. Following features are turned on

    • Containers
    • Hyper-V
    • Virtual Machine Platform
    • Windows HyperVisor Platform
    • Windows Subsystem for linux
  3. I see Virtualization enabled in Task manager as well



Have you checked: Install Docker Desktop on Windows | Docker Documentation ?
Im here thinking of Windows version

Hi @terpz ,

Mine is Win 11-64 Bit.

|Processor|11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz 2.80 GHz|
|Installed RAM|16.0 GB (15.7 GB usable)|
|System type|64-bit operating system, x64-based processor|

Windows features


Please try and enable wsl2:

Tried. Same error. Still the same error

Can someone help, please? This is a desperate call for help.

Docker Desktop had been working for me, but upon opening it today I’m getting the error “Hardware assisted virtualization and data execution protection must be enabled in the BIOS.”

Oddly, the Hyper-V feature seemed to have unchecked, but I’ve checked it to reinstall the feature and rebooted.

Windows 10 21H2 19044.1682
Docker Desktop 4.7.1

So: the Hyper-V, and Windows Subsystem for Linux features are enabled, as is WSL2. The BIOS setting remains the same as before; virtualisation is enabled.

I’ve tried:

  • Running Docker Desktop as administrator
  • Uninstalling and reinstalling Docker
  • Renaming “%appdata%\Docker” and “%appdata%\Docker Desktop” so that they’re recreated on start.

Somehow, it’d been turned off in the boto config, as shown by (Get-CimInstance -ClassName Win32_ComputerSystem).HypervisorPresent returning false.

Fixed with: bcdedit /set hypervisorlaunchtype auto and a reboot.

1 Like

WSL2 does not require the Hyper-V feature. It only depends on the “Windows Subsystem for Linux” and “Virtual Machine Platform” features. Windows Home doesn’t have the Hyper-V feature and WSL2 is still running like a charme.

It looks like hypervisorlaunchtype was set to off on your machine, which was confirmed by (Get-CimInstance -ClassName Win32_ComputerSystem).HypervisorPresent. Auto should have been the default behavior.

1 Like

It is also happen with me