Docker Community Forums

Share and learn in the Docker community.

Hello-world stucks

Hi there,

I am new to docker and tried to install it on a centos7.

Unable to find image 'hello-world:latest' locally
latest: Pulling from library/hello-world
78445dd45222: Pull complete
Digest: sha256:c5515758d4c5e1e838e9cd307f6c6a0d620b5e07e6f927b07d05f6d12a1ac8d7
Status: Downloaded newer image for hello-world:latest

But then nothing happens. No information message, no command line, nothing.

Here is the docker info running in another terminal session (after executing the above command):

Containers: 1
 Running: 0
 Paused: 0
 Stopped: 1
Images: 1
Server Version: 1.13.0
Storage Driver: vfs
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 03e5862ec0d8d3b3f750e19fca3ee367e13c090e
runc version: 2f7393a47307a16f8cee44a37b262e8b81021e3e
init version: 949e6fa
Kernel Version: 3.10.0-042stab120.11
Operating System: CentOS Linux 7 (Core)
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 2 GiB
Name: mqtt.illtalmakler.de
ID: PHEG:LFO2:HLCM:W2DW:Y4YM:JLJU:D2AJ:TKMC:5BQ3:SCMU:UTIW:5SE6
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No kernel memory limit support
WARNING: No oom kill disable support
Experimental: false
Insecure Registries:
 127.0.0.0/8
Live Restore Enabled: false

And here the installation output - if nessecary -

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.plusline.de
 * extras: ftp.plusline.de
 * updates: ftp.plusline.de
Resolving Dependencies
--> Running transaction check
---> Package docker-engine.x86_64 0:1.13.0-1.el7.centos will be installed
--> Processing Dependency: docker-engine-selinux >= 1.13.0-1.el7.centos for package: docker-engine-1.13.0-1.el7.centos.x86_64
--> Processing Dependency: libltdl.so.7()(64bit) for package: docker-engine-1.13.0-1.el7.centos.x86_64
--> Running transaction check
---> Package docker-engine-selinux.noarch 0:1.13.0-1.el7.centos will be installed
---> Package libtool-ltdl.x86_64 0:2.4.2-21.el7_2 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch      Version                Repository      Size
================================================================================
Installing:
 docker-engine            x86_64    1.13.0-1.el7.centos    docker-main     19 M
Installing for dependencies:
 docker-engine-selinux    noarch    1.13.0-1.el7.centos    docker-main     28 k
 libtool-ltdl             x86_64    2.4.2-21.el7_2         base            49 k

Transaction Summary
================================================================================
Install  1 Package (+2 Dependent packages)

Total download size: 19 M
Installed size: 65 M
Downloading packages:
(1/3): libtool-ltdl-2.4.2-21.el7_2.x86_64.rpm              |  49 kB   00:00
warning: /var/cache/yum/x86_64/7/docker-main/packages/docker-engine-selinux-1.13.0-1.el7.centos.noarch.rpm: Header V4 RSA/SHA512 Signature, key ID 2c52609d: NOKEY
Public key for docker-engine-selinux-1.13.0-1.el7.centos.noarch.rpm is not installed
(2/3): docker-engine-selinux-1.13.0-1.el7.centos.noarch.rp |  28 kB   00:00
(3/3): docker-engine-1.13.0-1.el7.centos.x86_64.rpm        |  19 MB   00:01
--------------------------------------------------------------------------------
Total                                               18 MB/s |  19 MB  00:01
Retrieving key from https://yum.dockerproject.org/gpg
Importing GPG key 0x2C52609D:
 Userid     : "Docker Release Tool (releasedocker) <docker@docker.com>"
 Fingerprint: 5811 8e89 f3a9 1289 7c07 0adb f762 2157 2c52 609d
 From       : https://yum.dockerproject.org/gpg
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : docker-engine-selinux-1.13.0-1.el7.centos.noarch             1/3
setsebool:  SELinux is disabled.
libsemanage.semanage_direct_install_info: docker module will be disabled after install due to default enabled status.
libsemanage.semanage_direct_install_info: Overriding docker module at lower priority 100 with module at priority 400.
  Installing : libtool-ltdl-2.4.2-21.el7_2.x86_64                           2/3
  Installing : docker-engine-1.13.0-1.el7.centos.x86_64                     3/3
  Verifying  : libtool-ltdl-2.4.2-21.el7_2.x86_64                           1/3
  Verifying  : docker-engine-selinux-1.13.0-1.el7.centos.noarch             2/3
  Verifying  : docker-engine-1.13.0-1.el7.centos.x86_64                     3/3

Installed:
  docker-engine.x86_64 0:1.13.0-1.el7.centos

Dependency Installed:
  docker-engine-selinux.noarch 0:1.13.0-1.el7.centos
  libtool-ltdl.x86_64 0:2.4.2-21.el7_2

Complete!

Any ideas?

Best wishes

Marc

How did you run it? Maybe you used pull instead of run?
Does docker run -ti ubuntu echo Test work?

same result :cry:

Unable to find image 'ubuntu:latest' locally
latest: Pulling from library/ubuntu
8aec416115fd: Pull complete
695f074e24e3: Pull complete
946d6c48c2a7: Pull complete
bc7277e579f0: Pull complete
2508cbcde94b: Pull complete
Digest: sha256:71cd81252a3563a03ad8daee81047b62ab5d892ebbfbf71cf53415f29c130950
Status: Downloaded newer image for ubuntu:latest

than nothing happens