How to run any exe application on docker

I am facing problem when I build and run my image. here is my docker file code.

FROM microsoft/nanoserver
MAINTAINER sagar@gmail.com
COPY name.exe /bin/
ENTRYPOINT [“name.exe/bin”]
CMD ["/bin/name.exe", “input1”, “output”]
To build I am using this : docker build -t my name .

When I build it it shows successfully but when I run this i am getting this errors.

ERROR
Docker\Resources\bin\docker.exe: Error response from daemon: container 7da4b32f71a7a0746aa472ae7c20f677ca1153cb75e05b6140a4fd8a758f‌​120f encountered an error during CreateProcess: failure in a Windows system call: The system cannot find the file specified. (0x2) extra info: {“ApplicationName”:"",“CommandLine”:“name.exe/bin / bin/name.exe input1 output”,“User”:"",“WorkingDirectory”:“C:\”,“Environment”:{}‌​,“EmulateConsole”:fa‌​lse,“CreateStdInPipe‌​”:true,“CreateStdOut‌​Pipe”:true,“CreateSt‌​dErrPipe”

maybe ENTRYPOINT should be ["/bin/name.exe"] and CMD should be ["input1", "output"]

1 Like

I tried with this also but getting same error.

really? your executable was name.exe/bin…is it still broken like this?

yes…its still not working