Can not runnig exe in windows container

i run dockerfile

#servercore its mine tag
FROM  servercore 
COPY ./prog./work/prog
CMD ["cmd.exe", "/c", "start /b C:\\work\\prog\\prog.exe"]

then inside of container i type tasklist and see my program in tasklist it takes up 10,000 kilobytes of memory
but the program do not work corectly. Next step i tried inside this windows server core run this .exe, and in this case my program takes up 60000k in tasklist and works correctly. How can і run exe by dockerfile ?
Also i replacd CMD to ENTRYPOINT but i have same result like on first case(10 000 k)

I believe you also opened this issue on Stackoverflow. :slight_smile: Can you please let us know what did you expect to see? Like, what indicates the exe is not running? How do you connect to this exe service?
Also, what is the docker run command to run this image?

1 Like

So I was on stackoverflow. I used tasklist and saw that the application was running, but it was taking up little memory. I was told that it was necessary to change the WORKDIR, because I was running the .exe but the program did not have access to the dll. Thank you for your activity!