Docker Community Forums

Share and learn in the Docker community.

How to setup proxy for Docker if the proxy requires domain id authentication


(Ezhang04) #1

I am trying Docker and the installation is done. Also I have setup the http proxy according to the guide available at https://docs.docker.com/engine/admin/systemd/. But when I try the “docker run --rm hello-world” command to evaluation the installation, I get the “Proxy Authentication Required” error. So obviously the proxy setting has issues. But since the installation with yum is successful, the proxy setting in /etc/yum.conf is correct. So the issue should be on the proxy setup for the Docker side.

As said, the corp proxy requires domain id authentication, so understand that there should be something wrong in /etc/systemd/system/docker.service.d/http-proxy.conf
Here is what I have in that file:
[Service]
Environment=“HTTP_PROXY=http://domainname\username:password@proxyip:port/”

But obviously the proxy username and password doesnot work as it is expected.

Also I have tried add below lines in that file, it doesn’t work either.
proxy_username=domain\username
proxy_password=password

Any experience or idea for what I should I do to correct this issue?


(Malouke) #2

Hi you sould made http://account:passwo@domaine:port (genarly 8080)