Docker Community Forums

Share and learn in the Docker community.

Http: server gave HTTP response to HTTPS client

(Pvsvamsi) #1

I am trying to setup docker machine across multiple hosts, in an insecure way. I have followed the official configuration guide for local registry and created a daemon.json placed in /etc/docker/daemon.json. When I try to connect to the remote docker daemon, I’m getting this error :

Unable to query docker version: Get http: server gave HTTP response to HTTPS client

I tried the same get request in the browser using http instead of https and got this response

my /etc/docker/daemon.json is

“insecure-registries”: [“”]


I’m registering the existing remote docker daemon on my host using this command

docker-machine create --driver none --url=tcp:// myRemoteDaemon


docker-machine env myRemoteDaemon

When I run this command on my host machine, it was throwing this error

Error checking TLS connection: Error checking and/or regenerating the certs: There was an error validating certificates for host “”: tls: oversized record received with length 20527

And the command “docker-machine ls” is giving


myRemoteDaemon - none Running tcp:// Unknown Unable to query docker version: Get http: server gave HTTP response to HTTPS client

docker info :

Containers: 9
Running: 0
Paused: 0
Stopped: 9
Images: 49
Server Version: 17.09.0-ce
Storage Driver: overlay
Backing Filesystem: xfs
Supports d_type: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
init version: 949e6fa
Security Options:
Profile: default
Kernel Version: 3.10.0-514.16.1.el7.x86_64
Operating System: CentOS Linux 7 (Core)
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 15.51GiB
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Experimental: false
Insecure Registries:
Live Restore Enabled: false

(Betonetotbo) #2

Did you solve it? I facing the same problem.

(Pvsvamsi) #3

I gave up on docker machine and moved to docker swarm cloud mode :slight_smile: