Docker Community Forums

Share and learn in the Docker community.

--insecure registry setting failing with Docker 1.12.1 and CentOS7

insecure-registry

(Aferragine) #1

I’m trying to access an insecure registry using the following command:
docker login

But I keep getting the following error:
Get https:///v1/users/: http: server gave HTTP response to HTTPS client

I’ve had no luck with this. It seems for whatever reason that the daemon is not taking the settings in /etc/sysconfig/docker even after I restart the daemon.

I’ve done plenty of Googling and from what I read, /etc/sysconfig/docker is the correct location on CentOS (Even though I also tried in /etc/default/docker).

I’ve also tried using the following lines:
DOCKER_OPTS="–insecure-registry “
other_args=”–insecure-registry "

Nothing seems to work. I also issue:
"ps aux | grep dockerd "
and don’t see the --insecure_registry setting anywhere.

Any ideas as to what could be wrong?