"I am unable to sign in to my account in Docker Desktop."

I’m using Docker Desktop version v4.28.0, and I’m unable to sign in to my Docker Desktop account. Additionally, when I run the command ‘docker search mysql’ in my command prompt, it returns an error message stating:
'Error response from daemon: Get "https://index.docker.io/v1/search?q=mysql&n=25": dialing index.docker.io:443 container via direct connection because <my machine> has no HTTPS proxy: connecting to 54.227.20.253:443: dial tcp 54.227.20.253:443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

Hello!

If you can’t log in to the docker hub, why don’t you refer to this article?

Please, share more information. You shared what error you get when you run docker search, but what do you get when you try to log in?

Regarding the search, it doesn’t seem to be a DNS issue, but I don’t understand the error message. For example why it mentiones “container”:

dialing index.docker.io:443 container via direct connection because

Since it also says

It seems to be a proxy issue like here:

Some posts are about DNS, but DNS uses port 53, not 443. DNS resolution already happened in this case.

I have the same top-level issue here, but it feels like deep linking from the web page redirect isn’t being honored by Docker Desktop. Did this break in 4.28.0 ?
Even with a flush of cookies and data in Chrome, the docker page prompts for login and even triggers the MacOS (Monterey 12.7.3) modal prompt to allow Docker Desktop to handle the deep link. At that point, the app does not gain focus and service the auth login.
I am able to run the docker query a above, so it doesn’t feel like a proxy issue on my side.


Follow up:
I ended up using the docker CLI to login with the same creds and it worked just fine. Not a stopper for me, as the host machine for DD is rarely rebooted.