I can not create repository, the button is missing

Hello,

The create repository button is missing from my profile in https://hub.docker.com/repositories

Meanwhile it solved by itself, at this moment the button is there.
Thank you

How? I can’t find the button either… :face_with_raised_eyebrow:

I have just checked it again at this moment, the button is not there …

I made 5-10 attempts to login / logout and the button has appeared.

Before it i cleared browser cache.

I can see the “Create a repository” button on the front page, it takes me to “https://hub.docker.com/repository/create” witch just directs me to my my own repositories page “https://hub.docker.com/repositories”. I have tried different browsers, clearing the cache and logging on and off about 10-20 times.

I managed to get the button to appear!
I did all of the above and re-selected my username in the drop down menu in the repository page.

2 Likes

It looks like some kind of deployment in kubernetes.
Sometime you can get access to old application, sometime to new.
Probability 90/10

I am having the same issue! I don’t see the button to create a new repository… :frowning:
I tried loggin on and off again but it doesn’t work.
Anybody managed to find a workaround?

re-selected my username in the drop down menu in the repository page

The suggestion by @hannez worked for me finally.
Although this is very weird…

2 Likes

@hannez works for me too, it seems there has some issues for docker hub page

Ah where’s the button? I was hoping it was just a browser issue… but no Firefox either

Oh actually I just reselected my user name from the top left dropdown, and then it re-appeared.

On the page that says, “There are no repositories in this namespace. Tip: Not finding your repository? Try switching namespace via the top left dropdown”.

After reselecting my username the button appeared

This button is still missing… Thankfully the workaround to explicitly select your username from the dropdown list works!

Let’s see how long it takes docker to spot and fix the issue…

Try disabling your AdBlock extension for https://hub.docker.com

Any solution !! I am still facing this issue

You need to select your usename from the drop down again and ‘Create Repo’ option will appear.

Hey guys, you gotta create an Org first and then go to repo page. Don’t waste time refreshing your page.