Docker Community Forums

Share and learn in the Docker community.

I cannot run Docker in Windows 11

I had Windows 10 and Docker. It worked good.
Then I have upgraded Windows 10-> Windows 11.
All is ok, but Docker Desktop displays: “Docker engine starting” and it did not complete.
After analyze I have detected that the service is not running

Hyper-V Host Compute Service Error: 0x800700005 Access denied
I think it is the real reason.

I understand that this is not Docker specific but I did not find any solutions.
May be somebody here had a simple problem and knows how to solve it.
Thank you!

What is your Docker Desktop version? I upgraded my Windows 10 to Windows 11 without any problem but I use the WSL2 backend for Linux containers. What do you use Docker for? Windows containers or Linux containers?

I have uninstalled\installed the Docker, now I have the latest version.
Usually I use containers for Linux and sometimes for windows. Just now I try to run Linux containers.
Also, I have tried to switch Docker to Windows etc, but it does not work because of Hyper-V service.