Docker Community Forums

Share and learn in the Docker community.

Incompatability with Symantec Endpoint Protection


(Awb12768) #1

I recently updated my system from Win2k16 insiders edition to Win2k19 insiders edition. It was a fresh install which went clean. However, I installed Symantec Endpoint Protection (SEP) as required by company policy. Doing so has prevented Hyper-V and Docker for Windows from functioning properly. I had similar problems on Win2k16 and had to remove SEP in order to do my development. I had high hopes that this had been addressed for Win2k19.

From the Docker perspective, I could pull images, but when I tried a run, no output would ever appear. Just a simple windows-server-core with a RUN CMD would not show output. After uninstalling SEP, the command worked as expected.

Hyper-V appeared affected as well. When I went to Hyper-V Manager, it indicated the Hyper-V management service was not running. It was set to automatic but was not running. I started it manually, but the following event log entries appeared:

A timeout was reached (30000 milliseconds) while waiting for the Hyper-V Host Compute Service service to connect.

The Hyper-V Host Compute Service service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.

Once again, removing SEP allowed Hyper-V to function correctly.

Is this a known problem?

OS Name: Windows Server 2019 Standard
OS Version: 10.0.17744 Build 17744
Docker:
Client:
Version: 17.10.0-ee-preview-3
API version: 1.33
Go version: go1.8.4
Git commit: 1649af8
Built: Fri Oct 6 17:52:28 2017
OS/Arch: windows/amd64

Server:
Version: 17.10.0-ee-preview-3
API version: 1.34 (minimum version 1.24)
Go version: go1.8.4
Git commit: b8571fd
Built: Fri Oct 6 18:01:48 2017
OS/Arch: windows/amd64
Experimental: true

All that is needed to reproduce is to install SEP. I used version 14.0.3892.1101.

Any insight is most appreciated.