Docker Community Forums

Share and learn in the Docker community.

Install on Mac Big Sur, I made a mess of things - failed cleanup - no daemon

So, I have two iMac running Big Sur. One is a very wimpy older model I use basically as a VNC machine to access a MacPro to play HiDef audio files through a DAC.

On my other machine which is a very beefy iMac 4k, lots of ram ssd … I first tried to install Docker via brew. It didn’t work daemon not running. Well, I’m stupid trying brew, and so DL the official Docker from the website and it installed, sort of, it doesn’t work as the daemon isn’t running either.
So … I installed it on the wimpy machine and unlike the other it asked for a password to install the daemon files, which the other machine didn’t, not brew nor proper installer. The wimpy machine works fine and is running a container to manage my T-Mobile “trashcan” modem.

Tried the uninstall, no joy. Searched for anything “docker” on the machine, didn’t find anything. Even with “find” at the root level in a shell window.

Need to find whatever the proper install package is looking for to prompt the password request to install the daemon code so it works. Made a list of files on the wimpy machine which didn’t enlighten me.

TIA
Frank

I don’t remember if I was asked for a password when I installed Docker Desktop on Mac but if it is a permission issue I would check the permission settings in “Security & Privacy” or whatever it was called in Big Sur (I have Monterey)

When you tried the official installation method, could you click on the desktop icon and start the application without starting the daemon or the Docker Desktop window itself couldn’t start?

I was definitely asked a password on the “wimpy” machine. Not on the other. Attempting to start Docker via the Dashboard or Command line would issue an error indicating that some sort of daemon or background process was not running. I expected the password, got it in the machine which works, but not on the other and nothing works, not even using the diagnostic options on the dock command line. There is something that got installed someplace that didn’t require root access which is preventing a fresh and proper install.
I shot myself in the foot and can’t find the bullet.