Installation Issue with Docker Desktop-4.11.0

Hi all,

Can someone please help me with installation of Docker Desktop-4.11.0 on Windows 10? All pre-requisites for Docker Desktop are installed and enabled, but am still getting the error:
Component CommunityInstaller.EnableFeaturesAction failed:
at CommunityInstaller.InstallerWorkflow. d_30MoveNext()"
— End a stack trace from previous location where the exception was thrown ----
at System.RuntimeExceptionServices.ExceptionDispatchInfo,Throw()
at System.RuntimeCompileServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at CommunityInstaller.InstallerWorkflow.d_23MoveNext() that I barely got.
(see annexed screenshot)

To find a reasonable solution to fix the aforementioned issue, I browsed before posting my thread here-unfortunately none of the provided solution on the StackOverflow or other websites worked for me (removed all folders of previous installtion, enabled server services, enabled & disabled hypervisor, installed last version wsl2 etc)

Thank in advance!

Kind regards,
Kanatbek

Then I’m afraid you’ll need to get in touch with Docker support, https://hub.docker.com/support/contact/. If you have a paid subscription then make sure to log in first.

And please come back here to post the solution for future readers. Or add it to an older post with recent responses, like Unable to install Docker Desktop 4.8.2: Component CommunityInstaller.EnableFeaturesAction failed: Not found.

1 Like

This message cought my eyes:

I don’t know what it does, but if it tries to enable required features, it is possible that it needs permission to check enabled features even if you enabled everything and it doesn’t have permission to do that. Are you trying to install it as an administrator? This is my only idea, so if you are trying as an Administrator, then I agree with @avbentem

1 Like

Hi Rimelek,

The issue remains the same even if I try to install Docker Desktop with an administrator role. I already wrote to Docker support team to figure out where the main issue lies.

Received an answer from Docker support team reagrding the issue I am encountering with installation of Docker Desktop on my PC. Here is the answer:

Thank you for contacting Docker Support.

Docker Desktop support is only available to Pro, Team, and Business customers. If you are a customer, please resubmit your ticket via Docker Hub, which will collect additional data we need to investigate it.

If you are not a customer, you could try the self-diagnose tool documented at Overview | Docker Documentation to see if it has any useful information.

Thank you.
Docker Support

According to this answer, I am wondering how I might be able to run diagnose of Docker on my PC, if the Docker is still not installed to run even if I would be a customer with Premium Access (PRO privileges), how it could collect additional data they need to investigate it.

Hope, to get an answer to fix the remaining issue on other websites.

Kind regards

Well, it was an interesting reply. Maybe they misundersood you. I don’t know, but you can try the issue tracker on GitHub. I found this issue there too:

The version is different, but the issue is still open. Since you probably won’t pay if you can’t install Docker Desktop, the developers will investigate it sooner or later. The error message here is a little different, (you did not get “not found”) so you may want to open a new issue and refer to this one as similar.

Just make sure you use code block on github when you share error messages and don’t highlight a part of the message with **message**. I don’t know if you noticed but some part of the error message in your original post is hidden. Use the code block button next time above the message input field: </>

1 Like

Hi Rimelek,

Thanks for precise explanation.

After scrutinizing the error and browsing on the internet, I realized that I first have to check the version of the laptop I am using currently, whether it is a Windows Education, Pro or Home. it looks like the Docker does not work on Windows Home version unless I am mistaken.

Kind regards,

The Issue with Installation of Docker Desktop-4.11.1 on Windows 10 solved!

It looks like the failed EnableFeatureAction was coming from the corrupted files on my device which not only was keeping from Updating the device, but also modules from enabling features.
Here is a screenshot of scan with reference to a corrupted file:

After fixing this issue above, I was able to update the device and install Docker.

Thanks all for giving me hints.

Kind regards,
Kanatbek

1 Like

Docker with the WSL2 backend works on Windows Home 21H1 and above. I know you already know that, I just wanted to make it clear for anyone else :slight_smile: Here are the reqirements: Install Docker Desktop on Windows | Docker Documentation

Thank you for helping the community by solving it and sharing the solution!